Prepare Open vSwitch 1.1.2 release.
[sliver-openvswitch.git] / debian / automake.mk
index 7c73831..85a4e3c 100644 (file)
@@ -5,9 +5,6 @@ EXTRA_DIST += \
        debian/control.modules.in \
        debian/copyright \
        debian/copyright.in \
-       debian/corekeeper.cron.daily \
-       debian/corekeeper.init \
-       debian/corekeeper.override \
        debian/dirs \
        debian/openvswitch-common.dirs \
        debian/openvswitch-common.install \
@@ -27,10 +24,6 @@ EXTRA_DIST += \
        debian/openvswitch-ipsec.dirs \
        debian/openvswitch-ipsec.init \
        debian/openvswitch-ipsec.install \
-       debian/openvswitch-pki-server.apache2 \
-       debian/openvswitch-pki-server.dirs \
-       debian/openvswitch-pki-server.install \
-       debian/openvswitch-pki-server.postinst \
        debian/openvswitch-pki.postinst \
        debian/openvswitch-switch.README.Debian \
        debian/openvswitch-switch.dirs \
@@ -47,15 +40,17 @@ EXTRA_DIST += \
        debian/python-openvswitch.dirs \
        debian/python-openvswitch.install \
        debian/rules \
-       debian/rules.modules
+       debian/rules.modules \
+       debian/source/format
 
 check-debian-changelog-version:
-       @if $(FGREP) '($(VERSION))' $(srcdir)/debian/changelog >/dev/null; \
-       then                                                               \
-         :;                                                               \
-       else                                                               \
-         echo "Update debian/changelog to mention version $(VERSION)";    \
-         exit 1;                                                          \
+       @DEB_VERSION=`echo '$(VERSION)' | sed 's/pre/~pre/'`;                \
+       if $(FGREP) '($(DEB_VERSION)' $(srcdir)/debian/changelog >/dev/null; \
+       then                                                                 \
+         :;                                                                 \
+       else                                                                 \
+         echo "Update debian/changelog to mention version $(VERSION)";      \
+         exit 1;                                                            \
        fi
 ALL_LOCAL += check-debian-changelog-version
 DIST_HOOKS += check-debian-changelog-version