Prepare Open vSwitch 1.1.2 release.
[sliver-openvswitch.git] / debian / automake.mk
index f493100..85a4e3c 100644 (file)
@@ -40,15 +40,17 @@ EXTRA_DIST += \
        debian/python-openvswitch.dirs \
        debian/python-openvswitch.install \
        debian/rules \
-       debian/rules.modules
+       debian/rules.modules \
+       debian/source/format
 
 check-debian-changelog-version:
-       @if $(FGREP) '($(VERSION))' $(srcdir)/debian/changelog >/dev/null; \
-       then                                                               \
-         :;                                                               \
-       else                                                               \
-         echo "Update debian/changelog to mention version $(VERSION)";    \
-         exit 1;                                                          \
+       @DEB_VERSION=`echo '$(VERSION)' | sed 's/pre/~pre/'`;                \
+       if $(FGREP) '($(DEB_VERSION)' $(srcdir)/debian/changelog >/dev/null; \
+       then                                                                 \
+         :;                                                                 \
+       else                                                                 \
+         echo "Update debian/changelog to mention version $(VERSION)";      \
+         exit 1;                                                            \
        fi
 ALL_LOCAL += check-debian-changelog-version
 DIST_HOOKS += check-debian-changelog-version