tunneling: Refresh IP header pointer after update_header().
[sliver-openvswitch.git] / debian / rules
index 0d0abf1..4a02a49 100755 (executable)
@@ -29,6 +29,7 @@ configure-stamp:
        dh_testdir
        test -e configure || ./boot.sh
        test -d _debian || mkdir _debian
+       echo $(DEB_BUILD_OPTIONS)
        echo $$CC
        cd _debian && ( \
                test -e Makefile || \
@@ -44,7 +45,10 @@ build-arch: build-arch-stamp
 build-arch-stamp: configure-stamp 
        $(MAKE) -C _debian
 ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
-       $(MAKE) -C _debian check
+       if $(MAKE) -C _debian check; then :; else \
+               cat _debian/tests/testsuite.log; \
+               exit 1; \
+       fi
 endif
        touch $@
 
@@ -60,7 +64,6 @@ clean:
        rm -rf _debian
        [ ! -f Makefile ] || $(MAKE) distclean
        dh_clean 
-       debconf-updatepo
 
 install: install-indep install-arch
 install-indep: build-indep
@@ -75,7 +78,6 @@ install-indep: build-indep
        chmod 755 debian/openvswitch-datapath-source/usr/src/modules/openvswitch-datapath/debian/rules
        cd debian/openvswitch-datapath-source/usr/src && tar -c modules | bzip2 -9 > openvswitch-datapath.tar.bz2 && rm -rf modules
        install -m644 debian/openvswitch-pki-server.apache2 debian/openvswitch-pki-server/etc/apache2/sites-available/openvswitch-pki
-       install -m1777 -d debian/corekeeper/var/log/core
 
 install-arch: build-arch
        dh_testdir
@@ -83,10 +85,8 @@ install-arch: build-arch
        dh_clean -k -s 
        dh_installdirs -s
        $(MAKE) -C _debian DESTDIR=$(CURDIR)/debian/openvswitch install
-       cp debian/openvswitch-switch-config.overrides debian/openvswitch-switch-config/usr/share/lintian/overrides/openvswitch-switch-config
        cp debian/openvswitch-switch.template debian/openvswitch-switch/usr/share/openvswitch/switch/default.template
        dh_install -s
-       env TERMINFO=debian/openvswitch-switchui/usr/share/terminfo tic -x extras/ezio/ezio3.ti
 
 # Must not depend on anything. This is to be called by
 # binary-arch/binary-indep
@@ -106,6 +106,7 @@ binary-common:
        dh_strip --dbg-package=openvswitch-dbg
        dh_compress 
        dh_fixperms -X var/log/core
+       dh_pysupport
        dh_perl
        dh_makeshlibs
        dh_installdeb
@@ -120,3 +121,9 @@ binary-arch: install-arch
 
 binary: binary-arch binary-indep
 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure
+
+# This GNU make extensions disables parallel builds for the current Makefile
+# but not for sub-Makefiles.  This is appropriate here because build-arch and
+# build-indep both invoke "make" on OVS, which can update some of the same
+# targets in ways that conflict (e.g. both update tests/testsuite).
+.NOTPARALLEL: