Add build number to datapath version and --version output from programs.
[sliver-openvswitch.git] / debian / rules
index cfcfbdb..5b25308 100755 (executable)
@@ -27,6 +27,8 @@ MA_DIR ?= /usr/share/modass
 
 -include debian/rules.ext
 
+DATAPATH_CONFIGURE_OPTS = --enable-snat
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
@@ -35,7 +37,7 @@ configure-stamp:
        cd _debian && ( \
                test -e Makefile || \
                ../configure --prefix=/usr --localstatedir=/var --enable-ssl \
-                       --enable-snat)
+                       $(DATAPATH_CONFIGURE_OPTS))
        $(ext_configure)
        touch configure-stamp
 
@@ -87,7 +89,7 @@ binary-modules: prep-deb-files
        dh_testroot
        dh_clean -k
        tar xzf openflow.tar.gz
-       cd openflow && ./configure --with-$(l2x)=$(KSRC)
+       cd openflow && ./configure --with-$(l2x)=$(KSRC) $(DATAPATH_CONFIGURE_OPTS)
        cd openflow && $(MAKE) -C $(dpdir)
        install -d -m755 $(DSTDIR)
        install -m644 openflow/$(dpdir)/*_mod.$(KO)o $(DSTDIR)/
@@ -96,7 +98,7 @@ binary-modules: prep-deb-files
        dh_compress
        dh_fixperms
        dh_installdeb
-       dh_gencontrol -- -v$(VERSION)
+       dh_gencontrol
        dh_md5sums
        dh_builddeb --destdir=$(DEB_DESTDIR)
 
@@ -131,7 +133,7 @@ binary-common:
        dh_installdocs
        dh_installexamples
        dh_installdebconf
-#      dh_installlogrotate
+       dh_installlogrotate
        dh_installinit
        dh_installman
        dh_link