Prepare Open vSwitch 1.1.2 release.
[sliver-openvswitch.git] / debian / rules
index 0d0abf1..6806980 100755 (executable)
 BUILD_NUMBER = 0
 
 ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-MAKEFLAGS += -j$(NUMJOBS)
+PARALLEL = -j$(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+else
+PARALLEL =
 endif
+MAKEFLAGS += $(PARALLEL)
 
 ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
 CFLAGS += -O0
@@ -29,6 +31,7 @@ configure-stamp:
        dh_testdir
        test -e configure || ./boot.sh
        test -d _debian || mkdir _debian
+       echo $(DEB_BUILD_OPTIONS)
        echo $$CC
        cd _debian && ( \
                test -e Makefile || \
@@ -44,7 +47,11 @@ build-arch: build-arch-stamp
 build-arch-stamp: configure-stamp 
        $(MAKE) -C _debian
 ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
-       $(MAKE) -C _debian check
+       if $(MAKE) -C _debian check TESTSUITEFLAGS='$(PARALLEL)'; then :; \
+       else \
+               cat _debian/tests/testsuite.log; \
+               exit 1; \
+       fi
 endif
        touch $@
 
@@ -60,7 +67,6 @@ clean:
        rm -rf _debian
        [ ! -f Makefile ] || $(MAKE) distclean
        dh_clean 
-       debconf-updatepo
 
 install: install-indep install-arch
 install-indep: build-indep
@@ -74,8 +80,6 @@ install-indep: build-indep
                > debian/openvswitch-datapath-source/usr/src/modules/openvswitch-datapath/debian/rules
        chmod 755 debian/openvswitch-datapath-source/usr/src/modules/openvswitch-datapath/debian/rules
        cd debian/openvswitch-datapath-source/usr/src && tar -c modules | bzip2 -9 > openvswitch-datapath.tar.bz2 && rm -rf modules
-       install -m644 debian/openvswitch-pki-server.apache2 debian/openvswitch-pki-server/etc/apache2/sites-available/openvswitch-pki
-       install -m1777 -d debian/corekeeper/var/log/core
 
 install-arch: build-arch
        dh_testdir
@@ -83,10 +87,8 @@ install-arch: build-arch
        dh_clean -k -s 
        dh_installdirs -s
        $(MAKE) -C _debian DESTDIR=$(CURDIR)/debian/openvswitch install
-       cp debian/openvswitch-switch-config.overrides debian/openvswitch-switch-config/usr/share/lintian/overrides/openvswitch-switch-config
        cp debian/openvswitch-switch.template debian/openvswitch-switch/usr/share/openvswitch/switch/default.template
        dh_install -s
-       env TERMINFO=debian/openvswitch-switchui/usr/share/terminfo tic -x extras/ezio/ezio3.ti
 
 # Must not depend on anything. This is to be called by
 # binary-arch/binary-indep
@@ -99,13 +101,14 @@ binary-common:
        dh_installexamples
        dh_installdebconf
        dh_installlogrotate
-       dh_installinit
+       dh_installinit -R
        dh_installcron
        dh_installman
        dh_link
        dh_strip --dbg-package=openvswitch-dbg
        dh_compress 
        dh_fixperms -X var/log/core
+       dh_pysupport
        dh_perl
        dh_makeshlibs
        dh_installdeb
@@ -120,3 +123,9 @@ binary-arch: install-arch
 
 binary: binary-arch binary-indep
 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure
+
+# This GNU make extensions disables parallel builds for the current Makefile
+# but not for sub-Makefiles.  This is appropriate here because build-arch and
+# build-indep both invoke "make" on OVS, which can update some of the same
+# targets in ways that conflict (e.g. both update tests/testsuite).
+.NOTPARALLEL: