hack to add installed files to the package.
[sfa.git] / geniwrapper.spec
index 469ed76..ac58e96 100644 (file)
@@ -43,18 +43,15 @@ make
 rm -rf $RPM_BUILD_ROOT
 make install DESTDIR="$RPM_BUILD_ROOT"
 
+# hack to add installed files to the package
+python -c "print '\n'.join(['%s*'%i.strip() for i in open('GENI_INSTALLED_FILES').readlines() if not i.strip().endswith('.pyc')])" |uniq > GENI_INSTALLED_FILES.all
+
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files
+%files -f GENI_INSTALLED_FILES.all
 %defattr(-,root,root)
-/etc/init.d/geniwrapper
-/etc/geni
-/usr/bin/geni-config-tty
-/usr/bin/gimport.py*
-/usr/bin/plc.py*
-/usr/bin/sfi.py*
-%(python -c "from distutils.sysconfig import get_python_lib(1); print get_python_lib()")/geni
 /usr/share/keyconvert
 
 %post