renamings going on
[sfa.git] / geniwrapper.spec
index 00219e0..bb5e2ea 100644 (file)
@@ -1,12 +1,12 @@
-
 %define url $URL: svn+ssh://svn.planet-lab.org/svn/geniwrapper/trunk/geniwrapper.spec $
 
-%define name geniwrapper
+%define name sfa
 %define version 0.8
 %define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
+%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
 
 Name: %{name}
 Version: %{version}
@@ -26,20 +26,29 @@ Requires: python
 Requires: pyOpenSSL >= 0.7
 Requires: m2crypto
 
-Summary: the GENI layer around MyPLC
+Summary: the GENI python libraries
+Group: Applications/System
+
+%package plc
+Summary: the GENI wrapper arounf MyPLC
 Group: Applications/System
+Requires: sfa
 
-%package sfi 
-Summary: the GENI layer around MyPLC - client side
+%package client
+Summary: the GENI experimenter-side CLI
 Group: Applications/System
+Requires: sfa
 
-%description 
+%description
+This package provides the python libraries that the Geni implementation requires
+
+%description plc
 Geniwrapper implements the Geni interface which serves as a layer
 between the existing PlanetLab interfaces and the Geni API.
 
-%description sfi
+%description client
 This package provides the client side of the Geni API, in particular
-sfi.py, together with less important utilities.
+sfi.py, together with other utilities.
 
 %prep
 %setup -q
@@ -54,27 +63,30 @@ make install DESTDIR="$RPM_BUILD_ROOT"
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files 
-%defattr(-,root,root)
-%config (noreplace) /etc/geni/geni_config
-%config (noreplace) /etc/geni/aggregates.xml
-%config (noreplace) /etc/geni/registries.xml
-/usr/share/keyconvert/
-/etc/init.d/geni
-%{_bindir}/geni-config-tty
-%{_bindir}/gimport.py
-%{_bindir}/plc.py
+%files
 %{python_sitelib}/*
+/usr/share/keyconvert/
+/var/www/html/wsdl/sfa.wsdl
 
-%files sfi
-%config (noreplace) /etc/geni/sfi_config
-%{_bindir}/sfi.py
-%{_bindir}/getNodes.py
-%{_bindir}/getRecord.py
-%{_bindir}/setRecord.py
-%{_bindir}/genidump.py
-
-%post
+%files plc
+%defattr(-,root,root)
+%config (noreplace) /etc/sfa/sfa_config
+%config (noreplace) /etc/sfa/aggregates.xml
+%config (noreplace) /etc/sfa/registries.xml
+/etc/init.d/sfa
+%{_bindir}/sfa-config-tty
+%{_bindir}/sfa-import-plc.py*
+%{_bindir}/sfa-plc.py*
+
+%files client
+%config (noreplace) /etc/sfa/sfi_config
+%{_bindir}/sfi.py*
+%{_bindir}/getNodes.py*
+%{_bindir}/getRecord.py*
+%{_bindir}/setRecord.py*
+%{_bindir}/genidump.py*
+
+%post plc
 chkconfig --add geni
 
 %changelog