(no commit message)
[linux-2.6.git] / kernel-2.6-planetlab.spec
index 923d969..97a3388 100644 (file)
@@ -10,6 +10,8 @@ Summary: The Linux kernel (the core of the Linux operating system)
 
 # Versions of various parts
 
+%define _with_netns 1
+
 #
 # Polite request for people who spin their own kernel rpms:
 # please modify the "release" field in a way that identifies
@@ -25,7 +27,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 
 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
 # updated every time the PL kernel is updated.
-%define vini_pl_patch 551
+%define vini_pl_patch 561
 
 %define specrelease 1
 
@@ -147,7 +149,15 @@ Patch520: linux-2.6-520-vnet+.patch
 Patch530: linux-2.6-530-built-by-support.patch
 Patch540: linux-2.6-540-oom-kill.patch
 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
-
+Patch560: linux-2.6-560-mmconf.patch
+Patch570: linux-2.6-570-tagxid.patch
+Patch590: linux-2.6-590-trellis-mm1-netns.patch
+Patch591: linux-2.6-591-unshare-netns.patch
+Patch592: linux-2.6-592-ztun-sb.patch
+Patch593: linux-2.6-593-egre.patch
+Patch594: linux-2.6-594-new_ns_pid.patch
+Patch595: linux-2.6-595-vserver-new-netns.patch
+Patch596: linux-2.6-596-debug.patch
 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
 
 %description
@@ -305,11 +315,6 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 10
 %ApplyPatch 20
 
-# NetNS patch for VINI
-%if 0%{?with_netns}
-%ApplyPatch 30
-%endif
-
 %ApplyPatch 100
 
 %ApplyPatch 200
@@ -322,14 +327,23 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 530
 %ApplyPatch 540
 %ApplyPatch 550
+%ApplyPatch 560
+%ApplyPatch 570
+
+# 
+%if 0%{?_with_netns}
+%ApplyPatch 590
+%ApplyPatch 591
+%ApplyPatch 592
+%ApplyPatch 593
+%ApplyPatch 594
+%ApplyPatch 595
+%ApplyPatch 596
+%endif
 
 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
 # break with later patches.
 
-%if 0%{?with_netns}
-%ApplyPatch %vini_pl_patch
-%endif
-
 rm -fr linux-%{kversion}
 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
 cd linux-%{kversion}