spec edition
[linux-2.6.git] / kernel-2.6-planetlab.spec
index a4671ae..cae736a 100644 (file)
@@ -10,6 +10,8 @@ Summary: The Linux kernel (the core of the Linux operating system)
 
 # Versions of various parts
 
+%define _with_netns 1
+
 #
 # Polite request for people who spin their own kernel rpms:
 # please modify the "release" field in a way that identifies
@@ -25,7 +27,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 
 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
 # updated every time the PL kernel is updated.
-%define vini_pl_patch 551
+%define vini_pl_patch 561
 
 %define specrelease 1
 
@@ -129,6 +131,7 @@ Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
 
 Patch010: linux-2.6-010-e1000e.patch
 Patch020: linux-2.6-020-build-id.patch
+Patch030: linux-2.6-030-netns.patch
 
 # These are patches picked up from Fedora/RHEL
 Patch100: linux-2.6-100-build-nonintconfig.patch
@@ -146,8 +149,12 @@ Patch520: linux-2.6-520-vnet+.patch
 Patch530: linux-2.6-530-built-by-support.patch
 Patch540: linux-2.6-540-oom-kill.patch
 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
-
-BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
+Patch560: linux-2.6-560-mmconf.patch
+Patch570: linux-2.6-570-tagxid.patch
+Patch590: linux-2.6-590-trellis-mm1-netns.patch
+Patch591: linux-2.6-591-unshare-netns.patch
+Patch592: linux-2.6-592-ztun-sb.patch
+Patch593: linux-2.6-593-egre.patch
 
 %description
 The kernel package contains the Linux kernel (vmlinuz), the core of any
@@ -304,11 +311,6 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 10
 %ApplyPatch 20
 
-# NetNS patch for VINI
-%if 0%{?with_netns}
-%ApplyPatch 30
-%endif
-
 %ApplyPatch 100
 
 %ApplyPatch 200
@@ -321,14 +323,20 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 530
 %ApplyPatch 540
 %ApplyPatch 550
+%ApplyPatch 560
+%ApplyPatch 570
+
+# 
+%if 0%{?_with_netns}
+%ApplyPatch 590
+%ApplyPatch 591
+%ApplyPatch 592
+%ApplyPatch 593
+%endif
 
 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
 # break with later patches.
 
-%if 0%{?with_netns}
-%ApplyPatch %vini_pl_patch
-%endif
-
 rm -fr linux-%{kversion}
 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
 cd linux-%{kversion}