Readd tagxid so the BootManager can work on all kernels.
[linux-2.6.git] / kernel-2.6-planetlab.spec
index 977a08c..f1a02bc 100644 (file)
@@ -17,12 +17,16 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # adding some text to the end of the version number.
 #
 %define sublevel 22
-%define patchlevel 12
+%define patchlevel 14
 %define kversion 2.6.%{sublevel}
 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
 
 %define vsversion 2.3.0.29
 
+# Will go away when VServer supports NetNS in mainline. Currently, it must be 
+# updated every time the PL kernel is updated.
+%define vini_pl_patch 561
+
 %define specrelease 1
 
 %define release vs%{vsversion}.%{specrelease}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -125,6 +129,7 @@ Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
 
 Patch010: linux-2.6-010-e1000e.patch
 Patch020: linux-2.6-020-build-id.patch
+Patch030: linux-2.6-030-netns.patch
 
 # These are patches picked up from Fedora/RHEL
 Patch100: linux-2.6-100-build-nonintconfig.patch
@@ -142,6 +147,8 @@ Patch520: linux-2.6-520-vnet+.patch
 Patch530: linux-2.6-530-built-by-support.patch
 Patch540: linux-2.6-540-oom-kill.patch
 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
+Patch560: linux-2.6-560-mmconf.patch
+Patch570: linux-2.6-570-tagxid.patch
 
 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
 
@@ -300,6 +307,11 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 10
 %ApplyPatch 20
 
+# NetNS patch for VINI
+%if 0%{?with_netns}
+%ApplyPatch 30
+%endif
+
 %ApplyPatch 100
 
 %ApplyPatch 200
@@ -312,7 +324,15 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 530
 %ApplyPatch 540
 %ApplyPatch 550
+%ApplyPatch 560
+%ApplyPatch 570
 
+# NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
+# break with later patches.
+
+%if 0%{?with_netns}
+%ApplyPatch %vini_pl_patch
+%endif
 
 rm -fr linux-%{kversion}
 ln -sf $KERNEL_PREVIOUS linux-%{kversion}