Fix device type and address length
[linux-2.6.git] / kernel-2.6-planetlab.spec
index 25416f2..f32e640 100644 (file)
@@ -10,6 +10,8 @@ Summary: The Linux kernel (the core of the Linux operating system)
 
 # Versions of various parts
 
+%define _with_netns 1
+
 #
 # Polite request for people who spin their own kernel rpms:
 # please modify the "release" field in a way that identifies
@@ -17,12 +19,16 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # adding some text to the end of the version number.
 #
 %define sublevel 22
-%define patchlevel 12
+%define patchlevel 14
 %define kversion 2.6.%{sublevel}
 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
 
 %define vsversion 2.3.0.29
 
+# Will go away when VServer supports NetNS in mainline. Currently, it must be 
+# updated every time the PL kernel is updated.
+%define vini_pl_patch 561
+
 %define specrelease 1
 
 %define release vs%{vsversion}.%{specrelease}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -123,6 +129,10 @@ Source30: kernel-%{kversion}-i686-xenU-%{pldistro}.config
 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
 %endif
 
+Patch010: linux-2.6-010-e1000e.patch
+Patch020: linux-2.6-020-build-id.patch
+Patch030: linux-2.6-030-netns.patch
+
 # These are patches picked up from Fedora/RHEL
 Patch100: linux-2.6-100-build-nonintconfig.patch
 
@@ -139,6 +149,13 @@ Patch520: linux-2.6-520-vnet+.patch
 Patch530: linux-2.6-530-built-by-support.patch
 Patch540: linux-2.6-540-oom-kill.patch
 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
+Patch560: linux-2.6-560-mmconf.patch
+Patch570: linux-2.6-570-tagxid.patch
+Patch590: linux-2.6-590-trellis-mm1-netns.patch
+Patch591: linux-2.6-591-unshare-netns.patch
+Patch592: linux-2.6-592-ztun-sb.patch
+Patch593: linux-2.6-593-egre.patch
+Patch594: linux-2.6-594-new_ns_pid.patch
 
 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
 
@@ -294,6 +311,9 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 0
 %endif
 
+%ApplyPatch 10
+%ApplyPatch 20
+
 %ApplyPatch 100
 
 %ApplyPatch 200
@@ -306,8 +326,22 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 530
 %ApplyPatch 540
 %ApplyPatch 550
+%ApplyPatch 560
+%ApplyPatch 570
+
+# 
+%if 0%{?_with_netns}
+%ApplyPatch 590
+%ApplyPatch 591
+%ApplyPatch 592
+%ApplyPatch 593
+%ApplyPatch 594
+%endif
 
+# NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
+# break with later patches.
 
+rm -fr linux-%{kversion}
 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
 cd linux-%{kversion}