Simplify, since there's only 1 xid associated with icmp.
[linux-2.6.git] / kernel-2.6.spec
index 8678389..1db746e 100644 (file)
@@ -27,11 +27,11 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # adding some text to the end of the version number.
 #
 %define sublevel 22
-%define patchlevel 14
+%define patchlevel 18
 %define kversion 2.6.%{sublevel}
 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
 
-%define vsversion 2.3.0.29
+%define vsversion 2.3.0.32
 
 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
 # updated every time the PL kernel is updated.
@@ -148,6 +148,7 @@ Patch100: linux-2.6-100-build-nonintconfig.patch
 # Linux-VServer
 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
 Patch210: linux-2.6-210-vserver-cpu-sched.patch
+Patch220: linux-2.6-220-lback-feat02.diff
 
 # IP sets
 Patch250: linux-2.6-250-ipsets.patch
@@ -161,6 +162,7 @@ Patch540: linux-2.6-540-oom-kill.patch
 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
 Patch560: linux-2.6-560-mmconf.patch
 Patch570: linux-2.6-570-tagxid.patch
+Patch580: linux-2.6-580-show-proc-virt.patch
 
 # See also the file named 'sources' here for the related checksums
 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
@@ -320,7 +322,7 @@ KERNEL_PREVIOUS=vanilla
   KERNEL_PREVIOUS=linux-%{kversion}-%1
 
 # This is where the patches get applied
-%if "0%{patchlevel}"
+%if 0%{?patchlevel}
 %ApplyPatch 0
 %endif
 
@@ -336,6 +338,7 @@ KERNEL_PREVIOUS=vanilla
 
 %ApplyPatch 200
 %ApplyPatch 210
+%ApplyPatch 220
 
 %ApplyPatch 250
 
@@ -347,6 +350,7 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 550
 %ApplyPatch 560
 %ApplyPatch 570
+%ApplyPatch 580
 
 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
 # break with later patches.
@@ -356,7 +360,7 @@ KERNEL_PREVIOUS=vanilla
 %endif
 
 # Run the mac80211 stuff in the kernel tree holding the last patch
-tar -xzf %{expand:%{PATCH600}}
+tar -xzf %{PATCH600}
 pushd mac80211-%{mac80211_version}
 mac80211_makeflags="KSRC=../$KERNEL_PREVIOUS"
 make $mac80211_makeflags modified
@@ -365,7 +369,7 @@ make $mac80211_makeflags patch_kernel
 popd
 
 # Untar iwlwifi in the same place - needs to be compiled later
-tar -xzf %{expand:%{PATCH601}}
+tar -xzf %{PATCH601}
 # the install target is broken: first it does not pass the right -b flag to depmod
 # second we do not need to invoke depmod at this stage anyway
 # let's add our own patch/stuff in this Makefile for manual install later on