Setting tag linux-2.6-27-29
[linux-2.6.git] / kernel-2.6.spec
index 527ab31..2ce647b 100644 (file)
@@ -28,7 +28,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # for module-tag.py - sublevel is used for the version (middle) part of tag names
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 8
+%define taglevel 29
 
 #
 # Polite request for people who spin their own kernel rpms:
@@ -37,21 +37,25 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # adding some text to the end of the version number.
 #
 %define sublevel 27
-%define patchlevel 46
+%define patchlevel 55
 %define kversion 2.6.%{sublevel}
 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
 
-%define vsversion 2.3.0.36.8
+%define vsversion 2.3.0.36.4
 
 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
 # updated every time the PL kernel is updated.
 %define vini_pl_patch 561
 
-%define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 %define signmodules 0
 %define make_target bzImage
+#%if "%{distro}" == "Fedora" && %{distrorelease} >= 13
+#%define KVERREL %{version}-%{release}
+#%else
 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
+#%endif
 
 # Override generic defaults with per-arch defaults
 
@@ -106,6 +110,15 @@ License: GPLv2
 Version: %{rpmversion}
 Release: %{release}
 ExclusiveOS: Linux
+
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12
+# this is a big and dirty work around for plymouth's dependencies on
+# Fedora 12. we don't even need plymouth on nodes.
+Provides: kernel = 2.6.29.1
+%else
+Provides: kernel = %{version}
+%endif
+
 Provides: kernel = %{version}
 Provides: kernel-drm = 4.3.0
 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
@@ -145,11 +158,17 @@ Source30: %{kernelconfig}-%{kversion}-i686-xenU.config
 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
 %endif
 
+Patch010: linux-2.6-010-e1000e-ich10lan.patch
+Patch017: linux-2.6-017-bnx2.patch
+
 Patch100: linux-2.6-100-build-nonintconfig.patch
 
 # Linux-VServer
 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
 Patch220: delta-ptrace-fix01.diff
+Patch230: delta-pivot-fix01.diff
+Patch240: delta-killperm-fix01.diff
+Patch241: delta-vx_rss_avail.patch
 
 # IP sets
 Patch250: linux-2.6-250-ipsets.patch
@@ -181,7 +200,6 @@ Patch710: linux-2.6-710-avoid-64bits-addr-pcmcia.patch
 
 # Ext4
 Patch800: linux-2.6-800-rename-ext4dev-to-ext4.patch
-Patch810: linux-2.6-810-ext4-cap-check-delay.patch
 
 #Patch900: linux-2.6-900-ext3_mount_default_to_barrier.patch
 #Patch910: linux-2.6-910-support_barriers_on_single_device_dm_devices.patch
@@ -347,11 +365,17 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 0
 %endif
 
+%ApplyPatch 10
+%ApplyPatch 17
+
 %ApplyPatch 100
 
 # vserver patch
 %ApplyPatch 200
 %ApplyPatch 220
+%ApplyPatch 230
+%ApplyPatch 240
+%ApplyPatch 241
 
 %ApplyPatch 250
 
@@ -382,7 +406,6 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 710
 
 %ApplyPatch 800
-%ApplyPatch 810
 
 %if 0
 %ApplyPatch 900
@@ -818,6 +841,71 @@ rm -f /lib/modules/%{KVERREL}uml/modules.*
 %endif
 
 %changelog
+* Fri Oct 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-29
+- bump to 2.6.27.55
+
+* Tue Oct 05 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-28
+- bump to 2.6.27.54
+
+* Fri Sep 24 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - linux-2.6-27-27
+- f12 workaround
+
+* Sun Aug 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-26
+- the check_stack_guard_page() has, under certain circumstances, side-effects which can not easily be undone in case the vx_rss_avail() fails
+
+* Fri Aug 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-25
+- Bump to 2.6.27.53
+
+* Fri Aug 20 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-24
+- Bump to 2.6.27.52
+
+* Wed Aug 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-23
+- Pick d7824370e26325c881b665350ce64fb0a4fde24a and 11ac552477e32835cb6970bf0a70c210807f5673 from Linus's tree
+
+* Sun Aug 15 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-22
+- Test 52-rc2
+
+* Fri Aug 13 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-21
+- Bump to 2.6.27.51 and include 2.6.27.51-rc1 patchset to test
+
+* Wed Aug 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-20
+- Fix wrong hash
+
+* Tue Aug 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-19
+- bump to 2.6.27.50
+
+* Mon Aug 02 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-18
+- bump to 2.6.27.49
+
+* Wed Jul 14 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-17
+- Enable CONFIG_CGROUP_SCHED instead of CONFIG_USER_SCHED for 64bit kernels
+
+* Fri Jul 09 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-16
+- support other Broadcom NetXtreme II BCM 5709 dual GbE variants
+
+* Mon Jul 05 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-15
+- Bump to 2.6.27.48
+
+* Tue Jun 15 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-14
+- fix softlock problems that causes kernel panics
+
+* Thu May 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-13
+- Bump to 2.6.27.47
+
+* Wed May 05 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-12
+- support 82567LM-3 Gigabit Network devices
+
+* Wed May 05 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-11
+- Drop VServer version string from package name otherwise RPM refuses to upgrade to newer tagged version saying that 0.36.8.9 > 0.36.4.10
+
+* Tue May 04 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-10
+- Revert to vs2.3.0.36.4
+
+* Tue Apr 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-27-9
+- config for wextoolbox OK
+- upgrade to patch-2.6.27.46-vs2.3.0.36.8
+- turn off delta-pivot-fix01.diff (which was tweaked btw)
+
 * Wed Apr 07 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-8
 - chopstix fixes & cleanups