change naming scheme
[linux-2.6.git] / kernel-2.6.spec
index a9ce616..3e5e5d0 100644 (file)
@@ -1,5 +1,20 @@
 %global __spec_install_pre %{___build_pre}
 
+#### Planet-Lab ####
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
+
+%{!?pldistro:%global pldistro planetlab}
+
+%define name linux-2.6
+%define module_version_varname sublevel
+%define taglevel 0
+
+%define sublevel 32
+#### Planet-Lab ####
+
 Summary: The Linux kernel
 
 # For a stable, released kernel, released_kernel should be 1. For rawhide
@@ -19,7 +34,7 @@ Summary: The Linux kernel
 %define rhel 1
 %if %{rhel}
 %define distro_build 19
-%define signmodules 1
+%define signmodules 0
 %else
 # fedora_build defines which build revision of this kernel version we're
 # building. Rather than incrementing forever, as with the prior versioning
@@ -126,7 +141,7 @@ Summary: The Linux kernel
 # Control whether we perform a compat. check against published ABI.
 %define with_kabichk   %{?_without_kabichk:   1} %{?!_without_kabichk: 0}
 # Control whether we perform a compat. check against published ABI.
-%define with_fips      %{?_without_fips:      0} %{?!_without_fips:      1}
+%define with_fips      %{?_without_fips:      1} %{?!_without_fips:      0}
 
 # Additional options for user-friendly one-off kernel building:
 #
@@ -208,7 +223,10 @@ Summary: The Linux kernel
 %if %{rhel}
 %define pkg_release %{distro_build}%{?dist}%{?buildid}
 %endif
-%define KVERREL %{rpmversion}-%{pkg_release}.%{_target_cpu}
+#### Planet-Lab ####
+%define pkg_release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+####
+%define KVERREL %{rpmversion}-%{pkg_release}-%{_target_cpu}
 
 %if !%{debugbuildsenabled}
 %define with_debug 0
@@ -506,7 +524,7 @@ AutoProv: yes\
 Name: kernel%{?variant}
 Group: System Environment/Kernel
 License: GPLv2
-URL: http://www.kernel.org/
+#URL: http://www.kernel.org/
 Version: %{rpmversion}
 Release: %{pkg_release}
 # DO NOT CHANGE THE 'ExclusiveArch' LINE TO TEMPORARILY EXCLUDE AN ARCHITECTURE BUILD.