tuned for module-tag.py
[linux-2.6.git] / kernel-2.6.spec
index f1a02bc..401fbe2 100644 (file)
@@ -1,3 +1,8 @@
+#
+# $Id$
+#
+%define url $URL$
+
 Summary: The Linux kernel (the core of the Linux operating system)
 
 # What parts do we want to build?  We must build at least one kernel.
@@ -10,6 +15,11 @@ Summary: The Linux kernel (the core of the Linux operating system)
 
 # Versions of various parts
 
+# for module-tag.py - sublevel is used for the version (middle) part of tag names
+%define name linux-2.6
+%define module_version_varname sublevel
+%define taglevel 1
+
 #
 # Polite request for people who spin their own kernel rpms:
 # please modify the "release" field in a way that identifies
@@ -27,9 +37,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # updated every time the PL kernel is updated.
 %define vini_pl_patch 561
 
-%define specrelease 1
-
-%define release vs%{vsversion}.%{specrelease}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 %{!?pldistro:%global pldistro planetlab}
 
@@ -79,7 +87,10 @@ Summary: The Linux kernel (the core of the Linux operating system)
 #
 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
 
-URL: http://svn.planet-lab.org/wiki/linux-2.6
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
 
 Name: kernel
 Group: System Environment/Kernel
@@ -112,14 +123,14 @@ BuildConflicts: rhbuildsys(DiskFree) < 500Mb
 
 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
 
-Source10: kernel-%{kversion}-i586-%{pldistro}.config
-Source11: kernel-%{kversion}-i686-%{pldistro}.config
-Source12: kernel-%{kversion}-x86_64-%{pldistro}.config
+Source10: %{pldistro}-%{kversion}-i586.config
+Source11: %{pldistro}-%{kversion}-i686.config
+Source12: %{pldistro}-%{kversion}-x86_64.config
 %if %{builduml}
-Source20: kernel-%{kversion}-i686-uml-%{pldidstro}.config
+Source20: %{pldistro}-%{kversion}-i686-uml.config
 %endif
 %if %{buildxen}
-Source30: kernel-%{kversion}-i686-xenU-%{pldistro}.config
+Source30: %{pldistro}-%{kversion}-i686-xenU.config
 %endif
 
 # Mainline patches
@@ -365,11 +376,11 @@ BuildKernel() {
 
     # Pick the right config file for the kernel we're building
     if [ -n "$Flavour" ] ; then
-      Config=kernel-%{kversion}-%{_target_cpu}-$Flavour-%{pldistro}.config
+      Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
     else
-      Config=kernel-%{kversion}-%{_target_cpu}-%{pldistro}.config
+      Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
       DevelLink=
     fi