work around for building with gcc4.3 on fedora 9
[linux-2.6.git] / kernel-2.6.spec
index 7b92464..6767543 100644 (file)
@@ -24,7 +24,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # for module-tag.py - sublevel is used for the version (middle) part of tag names
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 16
+%define taglevel 25
 
 #
 # Polite request for people who spin their own kernel rpms:
@@ -144,6 +144,9 @@ Source30: %{pldistro}-%{kversion}-i686-xenU.config
 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
 %endif
 
+%if "%{distroname}" == "f9"
+Patch001: linux-2.6-001-gcc43.patch
+%endif
 Patch010: linux-2.6-010-e1000e.patch
 Patch020: linux-2.6-020-build-id.patch
 Patch030: linux-2.6-030-netns.patch
@@ -181,6 +184,7 @@ Patch620: linux-2.6-620-kdb.patch
 Patch630: linux-2.6-630-sched-fix.patch
 Patch640: linux-2.6-640-netlink-audit-hack.patch
 Patch650: linux-2.6-650-hangcheck-reboot.patch
+Patch660: linux-2.6-660-nmi-watchdog-default.patch
 
 # See also the file named 'sources' here for the related checksums
 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
@@ -346,6 +350,10 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 0
 %endif
 
+%if "%{distroname}" == "f9"
+%ApplyPatch 1
+%endif
+
 %ApplyPatch 10
 %ApplyPatch 20
 
@@ -386,6 +394,7 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 630
 %ApplyPatch 640
 %ApplyPatch 650
+%ApplyPatch 660
 
 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
 # break with later patches.
@@ -847,6 +856,35 @@ rm -f /lib/modules/%{KVERREL}uml/modules.*
 %endif
 
 %changelog
+* Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-25
+- FUSE support.
+
+* Tue Aug 12 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-24
+- Enable nmi watchdog by default.
+
+* Mon Aug 04 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-23
+- Fixed a bug in my previous commit.
+
+* Mon Aug 04 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-22
+- * 1 fix for using udp/listening sockets via raw
+- * 1 fix to help codemux divide traffic in PlanetFlow
+
+* Fri Aug 01 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-21
+- Codemux calls setsockopt/SO_PEERCRED to set peer credentials on a socket, so that the connections it proxies to its clients are tagged for PlanetFlow. This hunk got lost somewhere along the way.
+
+* Thu Jul 31 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-20
+- Removed a debugging statement. Shows up a lot in the debug logs.
+
+* Wed Jul 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-19
+- Unbroke peercred setting.
+
+* Mon Jul 28 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-18
+- Now you can write your own TCP using packet sockets. As a side effect, tcptraceroute runs to completion including the
+- last hop.
+
+* Mon Jul 28 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-17
+- Optimize packet socket support to eliminate a packet copy.
+
 * Sun Jul 27 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-16
 - Missed this header file, which broke the compile.
 - I'll be doing another tag to include an optimization I left out of this version. This version is for Build only.