support EXT4 so we can boot f12
[linux-2.6.git] / kernel-2.6.spec
index 179578a..80590e9 100644 (file)
@@ -21,7 +21,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # for module-tag.py - sublevel is used for the version (middle) part of tag names
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 3
+%define taglevel 5
 
 #
 # Polite request for people who spin their own kernel rpms:
@@ -30,7 +30,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # adding some text to the end of the version number.
 #
 %define sublevel 27
-%define patchlevel 14
+%define patchlevel 45
 %define kversion 2.6.%{sublevel}
 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
 
@@ -140,8 +140,11 @@ Source30: %{pldistro}-%{kversion}-i686-xenU.config
 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
 %endif
 
+Patch100: linux-2.6-100-build-nonintconfig.patch
+
 # Linux-VServer
 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
+Patch220: delta-ptrace-fix01.diff
 
 # IP sets
 Patch250: linux-2.6-250-ipsets.patch
@@ -163,15 +166,20 @@ Patch560: linux-2.6-560-mmconf.patch
 Patch570: linux-2.6-570-tagxid.patch
 Patch580: linux-2.6-580-show-proc-virt.patch
 Patch590: linux-2.6-590-dcookies-mm.patch
+Patch591: linux-2.6-591-chopstix-intern.patch
 # Patch630: linux-2.6-630-sched-fix.patch
 Patch640: linux-2.6-640-netlink-audit-hack.patch
 Patch650: linux-2.6-650-hangcheck-reboot.patch
 Patch660: linux-2.6-660-nmi-watchdog-default.patch
-Patch680: linux-2.6-680-htb-hysteresis-tso.patch
+Patch680: linux-2.6-680-htb-hysteresis-tso.patch
 # Patch690: linux-2.6-690-web100.patch
 Patch700: linux-2.6-700-egre.patch
 Patch710: linux-2.6-710-avoid-64bits-addr-pcmcia.patch
 
+# Ext4
+Patch800: linux-2.6-800-rename-ext4dev-to-ext4.patch
+Patch810: linux-2.6-810-ext4-cap-check-delay.patch
+
 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
 
 %description
@@ -332,8 +340,9 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 0
 %endif
 
-# NetNS patch for VINI
+%ApplyPatch 100
 
+# vserver patch
 %ApplyPatch 200
 
 %ApplyPatch 250
@@ -356,12 +365,16 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 570
 %ApplyPatch 580
 %ApplyPatch 590
+%ApplyPatch 591
 %ApplyPatch 640
 %ApplyPatch 650
 %ApplyPatch 660
+%ApplyPatch 680
 %ApplyPatch 700
 %ApplyPatch 710
 
+%ApplyPatch 800
+%ApplyPatch 810
 
 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
 # break with later patches.
@@ -424,7 +437,7 @@ BuildKernel() {
     #Arch=`head -1 .config | cut -b 3-`
     echo USING ARCH=$Arch
 
-    make -s ARCH=$Arch oldconfig < /dev/null > /dev/null
+    make -s ARCH=$Arch nonint_oldconfig < /dev/null > /dev/null
     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
 %if %{headers}
@@ -792,6 +805,12 @@ rm -f /lib/modules/%{KVERREL}uml/modules.*
 %endif
 
 %changelog
+* Mon Feb 15 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-5
+- Update to 2.6.27.45
+
+* Mon Feb 15 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-4
+- Tagging trunk
+
 * Tue May 12 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-27-3
 - new tuntap patch available but not enabled
 - mac80211 and iwlwifi are now mainstream, no ext. sources anymore