add xidmask patch for mlab k32 kernel
[linux-2.6.git] / kernel-2.6.spec
index d9431bd..9505e99 100644 (file)
@@ -10,9 +10,10 @@ URL: %{SCMURL}
 
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 25
+# 131 borrowed from centos6.1, tg3 from 220 centos 6.2
+%define taglevel 131.220.xidmask1-vs2.3.0.36
 
-%define sublevel 32
+%define sublevel 33
 
 %if ("%{distro}" == "Fedora" && %{distrorelease} >= 12) || ("%{distro}" == "SL" && %{distrorelease} >= 6) || ("%{distro}" == "CentOS" && %{distrorelease} >= 6)
 %define modern_distro 1
@@ -232,6 +233,8 @@ Summary: The Linux kernel
 %define pkg_release %{distro_build}%{?dist}%{?buildid}
 %endif
 #### Planet-Lab ####
+#%define pkg_release %{taglevel}%{?pldistro:.%{pldistro}}.mlab%{?date:.%{date}}
+# this branch is now unique to the mlab build. so pldistro==mlab
 %define pkg_release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 #### Planet-Lab ####
 %define KVERREL %{rpmversion}-%{pkg_release}.%{_target_cpu}
@@ -681,6 +684,9 @@ Patch17: linux-2.6-640-netlink-audit-hack.patch
 Patch18: linux-2.6-650-hangcheck-reboot.patch
 Patch19: linux-2.6-660-nmi-watchdog-default.patch
 Patch20: linux-2.6-680-htb-hysteresis-tso.patch
+Patch21: linux-2.6-690-web100.patch
+Patch22: linux-2.6-700-bcm5720.patch
+Patch23: linux-2.6-710-xidmask.patch
 
 Patch10000: linux-2.6-10000-gcc-4.5.patch
 Patch10001: linux-2.6-10001-gcc-4.6-warnoff.patch
@@ -1000,6 +1006,9 @@ ApplyPatch linux-2.6-640-netlink-audit-hack.patch
 ApplyPatch linux-2.6-650-hangcheck-reboot.patch
 ApplyPatch linux-2.6-660-nmi-watchdog-default.patch
 ApplyPatch linux-2.6-680-htb-hysteresis-tso.patch
+ApplyPatch linux-2.6-690-web100.patch
+ApplyPatch linux-2.6-700-bcm5720.patch
+ApplyPatch linux-2.6-710-xidmask.patch
 ApplyPatch linux-2.6-10000-gcc-4.5.patch
 ApplyPatch linux-2.6-10001-gcc-4.6-warnoff.patch
 ApplyPatch linux-2.6-10002-gcc-4.6-sense_buffer.patch
@@ -1788,6 +1797,12 @@ fi
 %endif
 
 %changelog
+* Mon Nov 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-32-27
+- 2 places for pulling sources from in case of network outage
+
+* Wed Oct 05 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-26
+- Tweak to the f8 build-fixing patch
+
 * Tue Oct 04 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-32-25
 - Apply f8-build-fixing patch