PCI power management reset for kexec
[linux-2.6.git] / kernel-2.6.spec
index 5c6a155..99433e7 100644 (file)
@@ -46,10 +46,10 @@ Summary: The Linux kernel (the core of the Linux operating system)
 
 #%define updatelevel 1
 
-# Tweak for being able to issue updates with the same kernel version, but with
-# a different package version.
-%define kernelrelease vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
-%define packagerelease %{kernelrelease}%{?updatelevel:.%{updatelevel}}
+%define kernelrelease vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}%{?updatelevel:.%{updatelevel}}
+%define packagerelease %{kernelrelease}
+
+
 
 %{!?pldistro:%global pldistro planetlab}
 
@@ -160,6 +160,8 @@ Patch050: linux-2.6-050-getline.patch
 # These are patches picked up from Fedora/RHEL
 Patch100: linux-2.6-100-build-nonintconfig.patch
 
+Patch150: linux-2.6-150-cciss-allow-kexec-to-work.patch
+
 # Linux-VServer
 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
 Patch210: linux-2.6-210-vserver-cpu-sched.patch
@@ -204,6 +206,8 @@ Patch720: linux-2.6-720-bonding-layer23.patch
 Patch721: linux-2.6-721-bonding-layer3.patch
 Patch722: linux-2.6-722-bonding-rr.patch
 
+Patch800: linux-2.6-800-fix-4-bit-apicid-assumption.patch
+
 # See also the file named 'sources' here for the related checksums
 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
@@ -391,6 +395,8 @@ KERNEL_PREVIOUS=vanilla
 
 %ApplyPatch 100
 
+%ApplyPatch 150
+
 %ApplyPatch 200
 %ApplyPatch 210
 %ApplyPatch 220
@@ -432,6 +438,7 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 720
 %ApplyPatch 721
 %ApplyPatch 722
+%ApplyPatch 800
 
 
 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may