Let the spectator see all.
[linux-2.6.git] / kernel-2.6.spec
index 0713c93..9df532e 100644 (file)
@@ -24,7 +24,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # for module-tag.py - sublevel is used for the version (middle) part of tag names
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 8
+%define taglevel 13
 
 #
 # Polite request for people who spin their own kernel rpms:
@@ -155,6 +155,7 @@ Patch100: linux-2.6-100-build-nonintconfig.patch
 # Linux-VServer
 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
 Patch210: linux-2.6-210-vserver-cpu-sched.patch
+Patch220: delta-ptrace-fix01.diff
 
 # IP sets
 Patch250: linux-2.6-250-ipsets.patch
@@ -163,6 +164,12 @@ Patch250: linux-2.6-250-ipsets.patch
 Patch500: linux-2.6-500-vserver-filesharing.patch
 Patch510: linux-2.6-510-ipod.patch
 Patch520: linux-2.6-520-vnet+.patch
+Patch521: linux-2.6-521-packet-tagging.patch
+Patch522: linux-2.6-522-iptables-connection-tagging.patch
+Patch523: linux-2.6-523-raw-sockets.patch
+Patch524: linux-2.6-524-peercred.patch
+Patch525: linux-2.6-525-sknid-elevator.patch
+Patch526: linux-2.6-526-tun-tap.patch
 Patch530: linux-2.6-530-built-by-support.patch
 Patch540: linux-2.6-540-oom-kill.patch
 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
@@ -173,6 +180,7 @@ Patch590: linux-2.6-590-chopstix-intern.patch
 Patch620: linux-2.6-620-kdb.patch
 Patch630: linux-2.6-630-sched-fix.patch
 Patch640: linux-2.6-640-netlink-audit-hack.patch
+Patch650: linux-2.6-650-hangcheck-reboot.patch
 
 # See also the file named 'sources' here for the related checksums
 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
@@ -351,12 +359,21 @@ KERNEL_PREVIOUS=vanilla
 
 %ApplyPatch 200
 %ApplyPatch 210
+%ApplyPatch 220
 
 %ApplyPatch 250
 
 %ApplyPatch 500
 %ApplyPatch 510
-%ApplyPatch 520
+
+# VNET+ series
+%ApplyPatch 521
+%ApplyPatch 522
+%ApplyPatch 523
+%ApplyPatch 524
+%ApplyPatch 525
+%ApplyPatch 526
+
 %ApplyPatch 530
 %ApplyPatch 540
 %ApplyPatch 550
@@ -367,6 +384,7 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 620
 %ApplyPatch 630
 %ApplyPatch 640
+%ApplyPatch 650
 
 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
 # break with later patches.
@@ -828,6 +846,24 @@ rm -f /lib/modules/%{KVERREL}uml/modules.*
 %endif
 
 %changelog
+* Mon Jul 21 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-13
+- fix for tcpdump/tcp payloads
+
+* Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-12
+- * Bugfix in tuntap
+- * Attempt to fix TCP-payload-related problems with tcpdump
+
+* Wed Jul 09 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-11
+- * Split up VNET+ module into its component patches
+- * Added tun/tap support
+
+* Tue Jul 08 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-10
+- Filling a statically allocated buffer cannot fail, right?
+
+* Wed Jun 25 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-9
+- Enable the hangcheck timer driver, and build it in to the kernel.
+- Dump relevant data on the scheduler bug instead of BUGing.
+
 * Sat Jun 07 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-8
 - * Partial fix for the UDP-packet-pollution problem
 - * Support for PF_PACKET sockets