fix softlock problems that causes kernel panics, oscar goes to Daniel :)
[linux-2.6.git] / kernel-2.6.spec
index 3885cdd..b7a0b03 100644 (file)
@@ -51,7 +51,11 @@ Summary: The Linux kernel (the core of the Linux operating system)
 
 %define signmodules 0
 %define make_target bzImage
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 13
+%define KVERREL %{version}-%{release}
+%else
 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
+%endif
 
 # Override generic defaults with per-arch defaults
 
@@ -153,6 +157,7 @@ Patch100: linux-2.6-100-build-nonintconfig.patch
 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
 Patch220: delta-ptrace-fix01.diff
 Patch230: delta-pivot-fix01.diff
+Patch240: delta-killperm-fix01.diff
 
 # IP sets
 Patch250: linux-2.6-250-ipsets.patch
@@ -357,6 +362,7 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 200
 %ApplyPatch 220
 %ApplyPatch 230
+%ApplyPatch 240
 
 %ApplyPatch 250