fix softlock problems that causes kernel panics, oscar goes to Daniel :)
[linux-2.6.git] / kernel-2.6.spec
index 9fdef82..b7a0b03 100644 (file)
@@ -28,7 +28,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # for module-tag.py - sublevel is used for the version (middle) part of tag names
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 12
+%define taglevel 13
 
 #
 # Polite request for people who spin their own kernel rpms:
@@ -51,7 +51,11 @@ Summary: The Linux kernel (the core of the Linux operating system)
 
 %define signmodules 0
 %define make_target bzImage
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 13
+%define KVERREL %{version}-%{release}
+%else
 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
+%endif
 
 # Override generic defaults with per-arch defaults
 
@@ -153,6 +157,7 @@ Patch100: linux-2.6-100-build-nonintconfig.patch
 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
 Patch220: delta-ptrace-fix01.diff
 Patch230: delta-pivot-fix01.diff
+Patch240: delta-killperm-fix01.diff
 
 # IP sets
 Patch250: linux-2.6-250-ipsets.patch
@@ -357,6 +362,7 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 200
 %ApplyPatch 220
 %ApplyPatch 230
+%ApplyPatch 240
 
 %ApplyPatch 250
 
@@ -387,7 +393,6 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 710
 
 %ApplyPatch 800
-%ApplyPatch 810
 
 %if 0
 %ApplyPatch 900
@@ -823,6 +828,9 @@ rm -f /lib/modules/%{KVERREL}uml/modules.*
 %endif
 
 %changelog
+* Thu May 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-13
+- Bump to 2.6.27.47
+
 * Wed May 05 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-12
 - support 82567LM-3 Gigabit Network devices