solve the boot problems for the HP DL320 G6 boxes
[linux-2.6.git] / kernel-2.6.spec
index a863e47..d21fdff 100644 (file)
@@ -46,10 +46,10 @@ Summary: The Linux kernel (the core of the Linux operating system)
 
 #%define updatelevel 1
 
-# Tweak for being able to issue updates with the same kernel version, but with
-# a different package version.
-%define kernelrelease vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
-%define packagerelease %{kernelrelease}%{?updatelevel:.%{updatelevel}}
+%define kernelrelease vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}%{?updatelevel:.%{updatelevel}}
+%define packagerelease %{kernelrelease}
+
+
 
 %{!?pldistro:%global pldistro planetlab}
 
@@ -151,6 +151,7 @@ Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
 %endif
 
 Patch010: linux-2.6-010-e1000e.patch
+Patch015: linux-2.6-015-igb.patch
 Patch020: linux-2.6-020-build-id.patch
 Patch030: linux-2.6-030-netns.patch
 Patch040: linux-2.6-040-i_mutex-check.patch
@@ -203,6 +204,8 @@ Patch720: linux-2.6-720-bonding-layer23.patch
 Patch721: linux-2.6-721-bonding-layer3.patch
 Patch722: linux-2.6-722-bonding-rr.patch
 
+Patch800: linux-2.6-800-fix-4-bit-apicid-assumption.patch
+
 # See also the file named 'sources' here for the related checksums
 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
@@ -378,6 +381,7 @@ KERNEL_PREVIOUS=vanilla
 %endif
 
 %ApplyPatch 10
+%ApplyPatch 15
 %ApplyPatch 20
 
 # NetNS patch for VINI
@@ -430,6 +434,7 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 720
 %ApplyPatch 721
 %ApplyPatch 722
+%ApplyPatch 800
 
 
 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may