Setting tag linux-2.6-27-16
[linux-2.6.git] / kernel-2.6.spec
index 6d91e46..d4d30b7 100644 (file)
@@ -28,7 +28,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # for module-tag.py - sublevel is used for the version (middle) part of tag names
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 6
+%define taglevel 16
 
 #
 # Polite request for people who spin their own kernel rpms:
@@ -37,7 +37,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # adding some text to the end of the version number.
 #
 %define sublevel 27
-%define patchlevel 45
+%define patchlevel 48
 %define kversion 2.6.%{sublevel}
 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
 
@@ -47,11 +47,15 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # updated every time the PL kernel is updated.
 %define vini_pl_patch 561
 
-%define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 %define signmodules 0
 %define make_target bzImage
+#%if "%{distro}" == "Fedora" && %{distrorelease} >= 13
+#%define KVERREL %{version}-%{release}
+#%else
 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
+#%endif
 
 # Override generic defaults with per-arch defaults
 
@@ -145,12 +149,16 @@ Source30: %{kernelconfig}-%{kversion}-i686-xenU.config
 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
 %endif
 
+Patch010: linux-2.6-010-e1000e-ich10lan.patch
+Patch017: linux-2.6-017-bnx2.patch
+
 Patch100: linux-2.6-100-build-nonintconfig.patch
 
 # Linux-VServer
 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
 Patch220: delta-ptrace-fix01.diff
 Patch230: delta-pivot-fix01.diff
+Patch240: delta-killperm-fix01.diff
 
 # IP sets
 Patch250: linux-2.6-250-ipsets.patch
@@ -182,7 +190,9 @@ Patch710: linux-2.6-710-avoid-64bits-addr-pcmcia.patch
 
 # Ext4
 Patch800: linux-2.6-800-rename-ext4dev-to-ext4.patch
-Patch810: linux-2.6-810-ext4-cap-check-delay.patch
+
+#Patch900: linux-2.6-900-ext3_mount_default_to_barrier.patch
+#Patch910: linux-2.6-910-support_barriers_on_single_device_dm_devices.patch
 
 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
 
@@ -345,12 +355,16 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 0
 %endif
 
+%ApplyPatch 10
+%ApplyPatch 17
+
 %ApplyPatch 100
 
 # vserver patch
 %ApplyPatch 200
 %ApplyPatch 220
 %ApplyPatch 230
+%ApplyPatch 240
 
 %ApplyPatch 250
 
@@ -381,7 +395,11 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 710
 
 %ApplyPatch 800
-%ApplyPatch 810
+
+%if 0
+%ApplyPatch 900
+%ApplyPatch 910
+%endif
 
 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
 # break with later patches.
@@ -812,6 +830,38 @@ rm -f /lib/modules/%{KVERREL}uml/modules.*
 %endif
 
 %changelog
+* Fri Jul 09 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-16
+- support other Broadcom NetXtreme II BCM 5709 dual GbE variants
+
+* Mon Jul 05 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-15
+- Bump to 2.6.27.48
+
+* Tue Jun 15 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-14
+- fix softlock problems that causes kernel panics
+
+* Thu May 27 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-13
+- Bump to 2.6.27.47
+
+* Wed May 05 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-12
+- support 82567LM-3 Gigabit Network devices
+
+* Wed May 05 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-11
+- Drop VServer version string from package name otherwise RPM refuses to upgrade to newer tagged version saying that 0.36.8.9 > 0.36.4.10
+
+* Tue May 04 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-10
+- Revert to vs2.3.0.36.4
+
+* Tue Apr 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-27-9
+- config for wextoolbox OK
+- upgrade to patch-2.6.27.46-vs2.3.0.36.8
+- turn off delta-pivot-fix01.diff (which was tweaked btw)
+
+* Wed Apr 07 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-8
+- chopstix fixes & cleanups
+
+* Fri Apr 02 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-7
+- Update to 2.6.27.46
+
 * Mon Feb 15 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-6
 - support Ext4 in order to boot f12
 - fix "vcontext: pivot_root(): Invalid argument errors" while creating a guest with f12