ACPI: Idle C-states disabled by max_cstate should not disable the TSC (aka boot on...
[linux-2.6.git] / kernel-2.6.spec
index 6d23e75..f7158f6 100644 (file)
@@ -28,7 +28,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # for module-tag.py - sublevel is used for the version (middle) part of tag names
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 26
+%define taglevel 29
 
 #
 # Polite request for people who spin their own kernel rpms:
@@ -37,7 +37,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # adding some text to the end of the version number.
 #
 %define sublevel 27
-%define patchlevel 54
+%define patchlevel 55
 %define kversion 2.6.%{sublevel}
 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
 
@@ -110,6 +110,15 @@ License: GPLv2
 Version: %{rpmversion}
 Release: %{release}
 ExclusiveOS: Linux
+
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12
+# this is a big and dirty work around for plymouth's dependencies on
+# Fedora 12. we don't even need plymouth on nodes.
+Provides: kernel = 2.6.29.1
+%else
+Provides: kernel = %{version}
+%endif
+
 Provides: kernel = %{version}
 Provides: kernel-drm = 4.3.0
 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
@@ -195,6 +204,9 @@ Patch800: linux-2.6-800-rename-ext4dev-to-ext4.patch
 #Patch900: linux-2.6-900-ext3_mount_default_to_barrier.patch
 #Patch910: linux-2.6-910-support_barriers_on_single_device_dm_devices.patch
 
+# ACPI: Idle C-states disabled by max_cstate should not disable the TSC
+Patch920: linux-2.6-920-cstate.patch
+
 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
 
 %description
@@ -403,6 +415,8 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 910
 %endif
 
+%ApplyPatch 920
+
 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
 # break with later patches.
 
@@ -832,6 +846,15 @@ rm -f /lib/modules/%{KVERREL}uml/modules.*
 %endif
 
 %changelog
+* Fri Oct 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-29
+- bump to 2.6.27.55
+
+* Tue Oct 05 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-28
+- bump to 2.6.27.54
+
+* Fri Sep 24 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - linux-2.6-27-27
+- f12 workaround
+
 * Sun Aug 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-27-26
 - the check_stack_guard_page() has, under certain circumstances, side-effects which can not easily be undone in case the vx_rss_avail() fails