bump release
[linux-2.6.git] / kernel-2.6.spec
index 3256654..f83ed94 100644 (file)
@@ -14,7 +14,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 %define builddoc 0
 %define headers 1
 
-%{!?pldistro:%global pldistro planetlab}
+%{!?pldistro:%global pldistro coblitz}
 
 # default is to not build this - to override, use something like
 # kernel-SPECVARS := iwlwifi=1 
@@ -34,7 +34,7 @@ Summary: The Linux kernel (the core of the Linux operating system)
 # for module-tag.py - sublevel is used for the version (middle) part of tag names
 %define name linux-2.6
 %define module_version_varname sublevel
-%define taglevel 46
+%define taglevel 49.4
 
 #
 # Polite request for people who spin their own kernel rpms:
@@ -60,7 +60,12 @@ Summary: The Linux kernel (the core of the Linux operating system)
 
 %define signmodules 0
 %define make_target bzImage
+
+#%%if "%{distro}" == "Fedora" && %{distrorelease} >= 13
+#%%define KVERREL %{version}-%{kernelrelease}
+#%%else
 %define KVERREL %{PACKAGE_VERSION}-%{kernelrelease}
+#%%endif
 
 # Override generic defaults with per-arch defaults
 
@@ -157,17 +162,18 @@ Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
 
 Patch010: linux-2.6-010-e1000e.patch
 Patch015: linux-2.6-015-igb.patch
-# disabled
-#Patch016: linux-2.6-016-bnx2x.patch
+Patch017: linux-2.6-017-bnx2.patch
 Patch020: linux-2.6-020-build-id.patch
 Patch030: linux-2.6-030-netns.patch
 Patch040: linux-2.6-040-i_mutex-check.patch
 Patch050: linux-2.6-050-getline.patch
+Patch055: linux-2.6-055-ixgbe.patch
 
 # These are patches picked up from Fedora/RHEL
 Patch100: linux-2.6-100-build-nonintconfig.patch
 
 Patch150: linux-2.6-150-cciss-allow-kexec-to-work.patch
+Patch151: linux-2.6-151-cciss-SAS.patch
 
 # Linux-VServer
 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
@@ -205,7 +211,7 @@ Patch660: linux-2.6-660-nmi-watchdog-default.patch
 Patch670: linux-2.6-670-gcc43.patch
 %endif
 Patch680: linux-2.6-680-htb-hysteresis-tso.patch
-Patch690: linux-2.6-690-web100.patch
+#Patch690: linux-2.6-690-web100.patch
 Patch700: linux-2.6-700-fperm.patch
 Patch710: linux-2.6-710-avoid-64bits-addr-pcmcia.patch
 # This one is a backport from usptream.
@@ -216,6 +222,12 @@ Patch722: linux-2.6-722-bonding-rr.patch
 Patch800: linux-2.6-800-fix-4-bit-apicid-assumption.patch
 
 Patch810: linux-2.6-810-ich10.patch
+#Patch820: linux-2.6-820-megaraid.patch
+
+Patch900: linux-2.6-900-ext3_mount_default_to_barrier.patch
+Patch910: linux-2.6-910-support_barriers_on_single_device_dm_devices.patch
+
+Patch950: linux-2.6.950-ext3_backports.patch
 
 # See also the file named 'sources' here for the related checksums
 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
@@ -394,9 +406,7 @@ KERNEL_PREVIOUS=vanilla
 
 %ApplyPatch 10
 %ApplyPatch 15
-%if 0
-%ApplyPatch 16
-%endif
+%ApplyPatch 17
 %ApplyPatch 20
 
 # NetNS patch for VINI
@@ -405,10 +415,12 @@ KERNEL_PREVIOUS=vanilla
 %endif
 %ApplyPatch 40
 %ApplyPatch 50
+%ApplyPatch 55
 
 %ApplyPatch 100
 
 %ApplyPatch 150
+%ApplyPatch 151
 
 %ApplyPatch 200
 %ApplyPatch 210
@@ -453,7 +465,13 @@ KERNEL_PREVIOUS=vanilla
 %ApplyPatch 722
 %ApplyPatch 800
 %ApplyPatch 810
+%if 0
+%ApplyPatch 820
+%endif
+%ApplyPatch 900
+%ApplyPatch 910
 
+%ApplyPatch 950
 
 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
 # break with later patches.
@@ -546,6 +564,7 @@ BuildKernel() {
     make -s ARCH=$Arch INSTALL_HDR_PATH=$RPM_BUILD_ROOT/usr
     find $RPM_BUILD_ROOT/%{_includedir} -name \*.cmd -delete
     rm -f $RPM_BUILD_ROOT/%{_includedir}/{..,.}{check,install}*
+    rm -rf $RPM_BUILD_ROOT/usr/include/scsi
 %endif
 
 %if %{iwlwifi}
@@ -929,6 +948,16 @@ rm -f /lib/modules/%{KVERREL}uml/modules.*
 %endif
 
 %changelog
+* Fri May 07 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-22-48
+- Support next generation of HP Smart Array SAS/SATA controllers
+
+* Thu Apr 15 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-22-47
+- Tagging 22 branch with following changes;
+- * Make barrier=1 for ext3 filesystem,
+- * Support barriers on single device dm devices,
+- * Introduce various ext3 related fixes,
+- * Fix conflict between glibc-headers kernel-headers packages
+
 * Tue Mar 16 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - linux-2.6-22-46
 - every released package should have a tag in svn, so remove updatelevel from naming scheme and also change the variable name