build nodemanager doc only if present
[myplc.git] / myplc-docs.spec
index 0a09673..28420e6 100644 (file)
@@ -1,5 +1,5 @@
 %define name myplc-docs
-%define version 7.0
+%define version 7.1
 %define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -49,12 +49,15 @@ rm -f doc/PLCAPI.html
 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
 popd
 
+# nodemanager is now optional
+if [ -d nodemanager]; then
 pushd nodemanager
 # beware that making the pdf file somehow overwrites the html
 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
 rm -f doc/NMAPI.html
 make -C doc NMAPI.html || make -C doc NMAPI.html 
 popd
+fi
 
 # not everyone rebuilds monitor, so make it optional
 if [ -d monitor ] ; then
@@ -96,6 +99,9 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/planetlab/doc/
 
 %changelog
+* Sat Apr 30 2022 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-7.1-0
+- ready on f35
+
 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-7.0-0
 - suitable for python3 on both f27 and f29