build nodemanager doc only if present
[myplc.git] / myplc-docs.spec
index 2978684..28420e6 100644 (file)
@@ -1,5 +1,5 @@
 %define name myplc-docs
-%define version 5.3
+%define version 7.1
 %define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -49,12 +49,15 @@ rm -f doc/PLCAPI.html
 make -C doc PLCAPI.html || make -C doc PLCAPI.html 
 popd
 
+# nodemanager is now optional
+if [ -d nodemanager]; then
 pushd nodemanager
 # beware that making the pdf file somehow overwrites the html
 make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
 rm -f doc/NMAPI.html
 make -C doc NMAPI.html || make -C doc NMAPI.html 
 popd
+fi
 
 # not everyone rebuilds monitor, so make it optional
 if [ -d monitor ] ; then
@@ -96,6 +99,26 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/planetlab/doc/
 
 %changelog
+* Sat Apr 30 2022 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-7.1-0
+- ready on f35
+
+* Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-7.0-0
+- suitable for python3 on both f27 and f29
+
+* Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
+- takes care of creating plcapi log file
+
+* Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-3
+- tweaked renew_reminder for federation
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-2
+- tweaks in check-hrns.py
+- do not require PyXML any more
+
+* Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-1
+- review check-hrns for plcapi-5.3
+- add PLC_HRN_ROOT in usual plc-config-tty's settings
+
 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.2-5
 - reduce the scope of check-hrns.py script, now that the SFA layer handles this natively
 - add an rpm-sign dependency on feedora>=16