be stubborn on running latex as on f12 it behaves somewjat weird
[myplc.git] / myplc-docs.spec
index 970b0c9..ab88aa7 100644 (file)
@@ -1,6 +1,6 @@
 %define name myplc-docs
 %define version 5.0
-%define taglevel 15
+%define taglevel 17
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -42,26 +42,27 @@ rm -rf $RPM_BUILD_ROOT
 [ -d monitor ] || ln -s Monitor monitor 
 
 pushd plcapi
+# june2011 & f12, latex issues weird warnings, might need to try twice
+make -C doc PLCAPI.pdf || make -C doc PLCAPI.pdf 
 # beware that making the pdf file somehow overwrites the html
-make -C doc PLCAPI.pdf 
 rm -f doc/PLCAPI.html
-make -C doc PLCAPI.html 
+make -C doc PLCAPI.html || make -C doc PLCAPI.html 
 popd
 
 pushd nodemanager
 # beware that making the pdf file somehow overwrites the html
-make -C doc NMAPI.pdf 
+make -C doc NMAPI.pdf || make -C doc NMAPI.pdf
 rm -f doc/NMAPI.html
-make -C doc NMAPI.html 
+make -C doc NMAPI.html || make -C doc NMAPI.html 
 popd
 
 # not everyone rebuilds monitor, so make it optional
 if [ -d monitor ] ; then
 pushd monitor
 # beware that making the pdf file somehow overwrites the html
-make -C docs Monitor.pdf 
+make -C docs Monitor.pdf || make -C docs Monitor.pdf 
 rm -f docs/Monitor.html
-make -C docs Monitor.html 
+make -C docs Monitor.html || make -C docs Monitor.html 
 popd
 fi
 
@@ -95,6 +96,13 @@ rm -rf $RPM_BUILD_ROOT
 /var/www/html/planetlab/doc/
 
 %changelog
+* Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-17
+- fixed changelog, no change from 5.0-16
+
+* Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-16
+- requires ed for the plc.d/packages step
+- sirius initscript to handle stop and restart
+
 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-15
 - ignore steps in db-config.d if they have a '.' or '~' in their name