Provide versioned myplc so versioned Requires will work correctly.
[myplc.git] / myplc-native.spec
index 07f2067..0f27e5b 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name myplc-native
 %define version 5.0
-%define taglevel 0
+%define taglevel 1
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -63,6 +63,7 @@ Requires: bootcd-%{pldistro}-%{_arch}
 Requires: dnsmasq
 Requires: diffutils
 Requires: gzip
+Requires: vim-minimal
 Requires: findutils
 # planetlab stuff
 Requires: PLCWWW
@@ -70,8 +71,14 @@ Requires: nodeconfig
 Requires: PLCAPI
 Requires: bootstrapfs-%{pldistro}-%{_arch}
 Requires: myplc-docs
+Requires: myplc-release
 
-Provides: myplc
+# argh - ugly - we might wish to use something from build/config.%{pldistro} instead
+%if "%{pldistro}" == "onelab"
+Requires: dummynet_image
+%endif
+
+Provides: myplc = %version-%release
 
 %define debug_package %{nil}
 
@@ -88,14 +95,13 @@ system.
 %setup -q
 
 %build
+
+%install
 pushd MyPLC
 rm -rf $RPM_BUILD_ROOT
 ./build-native.sh %{pldistro} $RPM_BUILD_ROOT
 popd
 
-%install
-
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -107,7 +113,7 @@ if [ -n "$SUDO_USER" ] ; then
     # /usr/bin/sudo get created with non-readable permissions.
     find . -not -perm +0600 -exec chmod u+rw {} \;
     # Allow user to delete the built RPM(s)
-    chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
+    [ -d %{_rpmdir}/noarch ] && chown -h -R $SUDO_USER %{_rpmdir}/noarch
 fi
 
 %pre
@@ -182,13 +188,13 @@ fi
 %files
 %defattr(-,root,root,-)
 # Host startup script and configuration file
-/etc/myplc-release
 /etc/init.d/plc
 /etc/plc.d
 /etc/planetlab
 /etc/plc_sliceinitscripts/sirius
 /etc/support-scripts/gen_aliases.py*
 /etc/support-scripts/renew_reminder.py*
+/etc/support-scripts/renew_reminder_logrotate
 /usr/bin/plc-config
 /usr/bin/plc-config-tty
 /usr/bin/db-config
@@ -200,10 +206,12 @@ fi
 /usr/bin/mtail.py*
 /usr/bin/check-ssl-peering.py*
 /usr/share/myplc
-/var/www/html/install-rpms/%{pldistro}-%{_arch}
-/var/www/html/install-rpms/planetlab
 
 %changelog
+* Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
+- First iteration of new data model
+- Bunch of various fixes
+
 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
 - Removed proper ops from planetflow slice.