Provide versioned myplc so versioned Requires will work correctly.
[myplc.git] / myplc-native.spec
index 1731b3d..0f27e5b 100644 (file)
@@ -71,13 +71,14 @@ Requires: nodeconfig
 Requires: PLCAPI
 Requires: bootstrapfs-%{pldistro}-%{_arch}
 Requires: myplc-docs
+Requires: myplc-release
 
 # argh - ugly - we might wish to use something from build/config.%{pldistro} instead
 %if "%{pldistro}" == "onelab"
 Requires: dummynet_image
 %endif
 
-Provides: myplc
+Provides: myplc = %version-%release
 
 %define debug_package %{nil}
 
@@ -94,14 +95,13 @@ system.
 %setup -q
 
 %build
+
+%install
 pushd MyPLC
 rm -rf $RPM_BUILD_ROOT
 ./build-native.sh %{pldistro} $RPM_BUILD_ROOT
 popd
 
-%install
-
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -188,13 +188,13 @@ fi
 %files
 %defattr(-,root,root,-)
 # Host startup script and configuration file
-/etc/myplc-release
 /etc/init.d/plc
 /etc/plc.d
 /etc/planetlab
 /etc/plc_sliceinitscripts/sirius
 /etc/support-scripts/gen_aliases.py*
 /etc/support-scripts/renew_reminder.py*
+/etc/support-scripts/renew_reminder_logrotate
 /usr/bin/plc-config
 /usr/bin/plc-config-tty
 /usr/bin/db-config