needed when building *only* myplc-native
[myplc.git] / myplc-native.spec
index 981e431..15da9b1 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name myplc-native
 %define version 4.2
-%define taglevel 9
+%define taglevel 15
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -59,8 +59,6 @@ Requires: php
 Requires: xmlsec1-openssl
 Requires: postgresql
 Requires: openssh
-Requires: cvs
-Requires: dev
 Requires: bootcd-%{pldistro}-%{_arch}
 Requires: dnsmasq
 Requires: diffutils
@@ -71,6 +69,7 @@ Requires: PLCWWW
 Requires: nodeconfig
 Requires: PLCAPI
 Requires: bootstrapfs-%{pldistro}-%{_arch}
+Requires: myplc-docs
 
 Provides: myplc
 
@@ -108,7 +107,7 @@ if [ -n "$SUDO_USER" ] ; then
     # /usr/bin/sudo get created with non-readable permissions.
     find . -not -perm +0600 -exec chmod u+rw {} \;
     # Allow user to delete the built RPM(s)
-    chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
+    [ -d %{_rpmdir}/%{_arch} ] && chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
 fi
 
 %pre
@@ -154,23 +153,6 @@ fi
 pushd /usr/share/myplc &> /dev/null
 python plc_config.py build
 python plc_config.py install
-# build drupal docs - this is crappy but at least we keep PLCAPI out
-# also, we copy everythong in the same place
-mkdir -p /var/www/html/planetlab/doc
-if [ -f /usr/share/plc_api/doc/PLCAPI.html ] ; then
-    cp /usr/share/plc_api/doc/PLCAPI.{html,pdf} /var/www/html/planetlab/doc
-    ./docbook2drupal.sh "PLCAPI Documentation" \
-       /var/www/html/planetlab/doc/PLCAPI.html \
-       /var/www/html/planetlab/doc/PLCAPI.php
-fi || :
-# same for the PLCAPI doc
-if [ -f /usr/share/myplc/doc/myplc.html ] ; then
-    cp /usr/share/myplc/doc/myplc.{html,pdf} /var/www/html/planetlab/doc
-    ./docbook2drupal.sh "Myplc User Guide" \
-       /var/www/html/planetlab/doc/myplc.html \
-       /var/www/html/planetlab/doc/myplc.php
-fi || :
-
 popd &> /dev/null
 
 %triggerpostun -- %{name}
@@ -216,10 +198,34 @@ fi
 /usr/bin/mtail.py*
 /usr/bin/check-ssl-peering.py*
 /usr/share/myplc
-/var/www/html/install-rpms/%{pldistro}-%{_arch}
-/var/www/html/install-rpms/planetlab
 
 %changelog
+* Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
+- Removed proper ops from planetflow slice.
+
+* Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
+- myplc-native requires myplc-docs
+- fixed doc build by locating locally installed DTDs at build-time
+
+* Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
+- turn myplc-docs off for now
+
+* Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
+- figures in doc package
+
+* Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
+- no more doc packaged outside of myplc-docs - doc/ cleaned up 
+- chroot packaging does not have docs anymore
+- 'cvs' and 'dev' not required from myplc-native anymore
+- cosmetic change in kml output
+
+* Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
+- defaults for *_IP conf vars now void, expect more accurate /etc/hosts
+- gethostbyname uses python rather than perl (hope this shrinks deps) 
+- doc: reviewed myplc doc - deprecated everything related to myplc-devel
+- doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
+- make sync now works towards vserver-based myplc only 
+
 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
 - 
 - added vsys 'pfmount' script to the default netflow slice attributes.