Add VLIMIT_OPENFD limit, and change the min_role_id to admin (as the comment says).
[myplc.git] / myplc-native.spec
index 56dce61..283d2e3 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name myplc-native
 %define version 4.2
-%define taglevel 17
+%define taglevel 18
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -72,6 +72,11 @@ Requires: PLCAPI
 Requires: bootstrapfs-%{pldistro}-%{_arch}
 Requires: myplc-docs
 
+# argh - ugly - we might wish to use something from build/config.%{pldistro} instead
+%if "%{pldistro}" == "onelab"
+Requires: dummynet_image
+%endif
+
 Provides: myplc
 
 %define debug_package %{nil}
@@ -108,7 +113,7 @@ if [ -n "$SUDO_USER" ] ; then
     # /usr/bin/sudo get created with non-readable permissions.
     find . -not -perm +0600 -exec chmod u+rw {} \;
     # Allow user to delete the built RPM(s)
-    [ -d %{_rpmdir}/%{_arch} ] && chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
+    [ -d %{_rpmdir}/noarch ] && chown -h -R $SUDO_USER %{_rpmdir}/noarch
 fi
 
 %pre
@@ -201,6 +206,10 @@ fi
 /usr/share/myplc
 
 %changelog
+* Wed Sep 03 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-18
+- onelab distro requires the dummynet_image package with myplc-native
+- (onelab distro does not build chroot-myplc anymore)
+
 * Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-17
 - Remove iptables conf_file.  Now in iptables module.
 - Arch specific download directory now in /data for chrooted myplc