Added 'capabilities' slice attr to default set of slice attrs.
[myplc.git] / myplc-native.spec
index 1c06b05..8e63680 100644 (file)
@@ -1,17 +1,28 @@
-Vendor: PlanetLab
-Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 4.0
-URL: http://cvs.planet-lab.org/cvs/myplc
+#
+# $Id$
+#
+%define url $URL$
+
+%define name myplc-native
+%define version 4.2
+%define taglevel 3
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Summary: PlanetLab Central (PLC) Portable Installation
-Name: myplc-native
-Version: 0.5
-Release: 4%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+Name: %{name}
+Version: %{version}
+Release: %{release}
 License: PlanetLab
 Group: Applications/Systems
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
+
 Requires: bzip2
 Requires: sendmail-cf
 Requires: tar 
@@ -24,6 +35,7 @@ Requires: expect
 Requires: php-pgsql
 Requires: curl
 Requires: python-pycurl
+Requires: python-psycopg2
 Requires: httpd
 Requires: rsync
 Requires: mod_python
@@ -34,8 +46,6 @@ Requires: SOAPpy
 Requires: vixie-cron
 Requires: yum
 Requires: php-gd
-Requires: PLCWWW
-Requires: PLCAPI
 Requires: PyXML
 Requires: sendmail
 Requires: python >= 2.4
@@ -55,6 +65,13 @@ Requires: dnsmasq
 Requires: diffutils
 Requires: gzip
 Requires: findutils
+# planetlab stuff
+Requires: PLCWWW
+Requires: nodeconfig
+Requires: PLCAPI
+Requires: bootstrapfs
+
+Provides: myplc
 
 %define debug_package %{nil}
 
@@ -78,6 +95,7 @@ popd
 
 %install
 
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -132,6 +150,10 @@ if [ -x /sbin/chkconfig ] ; then
     /sbin/chkconfig --add plc
     /sbin/chkconfig plc on
 fi
+pushd /usr/share/myplc &> /dev/null
+python plc_config.py build
+python plc_config.py install
+popd &> /dev/null
 
 %triggerpostun -- %{name}
 # 0 = erase, 1 = upgrade
@@ -161,19 +183,25 @@ fi
 %defattr(-,root,root,-)
 # Host startup script and configuration file
 /etc/init.d/plc
+/etc/plc.d
+/etc/planetlab
+/var/www/html/install-rpms/planetlab
 /usr/bin/plc-config
 /usr/bin/plc-config-tty
 /usr/bin/db-config
 /usr/bin/dns-config
-/usr/bin/gen-sites-xml.py*
-/usr/bin/gen-slices-xml-05.py*
-/usr/bin/gen-static-content.py*
-/etc/plc.d
-/etc/planetlab
-/var/www/html/install-rpms/planetlab
+/usr/bin/plc-map.py*
+/usr/bin/clean-empty-dirs.py*
+/usr/bin/mtail.py*
+/usr/bin/check-ssl-peering.py*
+/usr/share/myplc
 
 %changelog
+* Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
+- refresh-peer.py removed (duplicate with PLCAPI)
+- plc.d/ scripts cleaned up
+- sirius initscript updated
+- slice auto renewal fixed
+
 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
 - initial build.
-
-