add an entry for the monitor server. this value will be needed at the nodes.
[myplc.git] / myplc-native.spec
index 158d60a..e518500 100644 (file)
@@ -5,7 +5,7 @@
 
 %define name myplc-native
 %define version 5.0
-%define taglevel 0
+%define taglevel 1
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -71,6 +71,7 @@ Requires: nodeconfig
 Requires: PLCAPI
 Requires: bootstrapfs-%{pldistro}-%{_arch}
 Requires: myplc-docs
+Requires: myplc-release
 
 # argh - ugly - we might wish to use something from build/config.%{pldistro} instead
 %if "%{pldistro}" == "onelab"
@@ -94,14 +95,13 @@ system.
 %setup -q
 
 %build
+
+%install
 pushd MyPLC
 rm -rf $RPM_BUILD_ROOT
 ./build-native.sh %{pldistro} $RPM_BUILD_ROOT
 popd
 
-%install
-
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -188,13 +188,13 @@ fi
 %files
 %defattr(-,root,root,-)
 # Host startup script and configuration file
-/etc/myplc-release
 /etc/init.d/plc
 /etc/plc.d
 /etc/planetlab
 /etc/plc_sliceinitscripts/sirius
 /etc/support-scripts/gen_aliases.py*
 /etc/support-scripts/renew_reminder.py*
+/etc/support-scripts/renew_reminder_logrotate
 /usr/bin/plc-config
 /usr/bin/plc-config-tty
 /usr/bin/db-config
@@ -206,10 +206,12 @@ fi
 /usr/bin/mtail.py*
 /usr/bin/check-ssl-peering.py*
 /usr/share/myplc
-/var/www/html/install-rpms/%{pldistro}-%{_arch}
-/var/www/html/install-rpms/planetlab
 
 %changelog
+* Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
+- First iteration of new data model
+- Bunch of various fixes
+
 * Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
 - Removed proper ops from planetflow slice.