add an entry for the monitor server. this value will be needed at the nodes.
[myplc.git] / myplc-native.spec
index ebc137e..e518500 100644 (file)
@@ -4,8 +4,8 @@
 %define url $URL$
 
 %define name myplc-native
-%define version 4.2
-%define taglevel 8
+%define version 5.0
+%define taglevel 1
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -59,18 +59,24 @@ Requires: php
 Requires: xmlsec1-openssl
 Requires: postgresql
 Requires: openssh
-Requires: cvs
-Requires: dev
 Requires: bootcd-%{pldistro}-%{_arch}
 Requires: dnsmasq
 Requires: diffutils
 Requires: gzip
+Requires: vim-minimal
 Requires: findutils
 # planetlab stuff
 Requires: PLCWWW
 Requires: nodeconfig
 Requires: PLCAPI
 Requires: bootstrapfs-%{pldistro}-%{_arch}
+Requires: myplc-docs
+Requires: myplc-release
+
+# argh - ugly - we might wish to use something from build/config.%{pldistro} instead
+%if "%{pldistro}" == "onelab"
+Requires: dummynet_image
+%endif
 
 Provides: myplc
 
@@ -89,14 +95,13 @@ system.
 %setup -q
 
 %build
+
+%install
 pushd MyPLC
 rm -rf $RPM_BUILD_ROOT
 ./build-native.sh %{pldistro} $RPM_BUILD_ROOT
 popd
 
-%install
-
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -108,7 +113,7 @@ if [ -n "$SUDO_USER" ] ; then
     # /usr/bin/sudo get created with non-readable permissions.
     find . -not -perm +0600 -exec chmod u+rw {} \;
     # Allow user to delete the built RPM(s)
-    chown -h -R $SUDO_USER %{_rpmdir}/%{_arch}
+    [ -d %{_rpmdir}/noarch ] && chown -h -R $SUDO_USER %{_rpmdir}/noarch
 fi
 
 %pre
@@ -183,26 +188,61 @@ fi
 %files
 %defattr(-,root,root,-)
 # Host startup script and configuration file
-/etc/myplc-release
 /etc/init.d/plc
 /etc/plc.d
 /etc/planetlab
 /etc/plc_sliceinitscripts/sirius
 /etc/support-scripts/gen_aliases.py*
 /etc/support-scripts/renew_reminder.py*
-/var/www/html/install-rpms/%{pldistro}-%{_arch}
-/var/www/html/install-rpms/planetlab
+/etc/support-scripts/renew_reminder_logrotate
 /usr/bin/plc-config
 /usr/bin/plc-config-tty
 /usr/bin/db-config
 /usr/bin/dns-config
 /usr/bin/plc-map.py*
+/usr/bin/plc-kml.py*
+/usr/bin/refresh-peer.py*
 /usr/bin/clean-empty-dirs.py*
 /usr/bin/mtail.py*
 /usr/bin/check-ssl-peering.py*
 /usr/share/myplc
 
 %changelog
+* Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-5.0-1
+- First iteration of new data model
+- Bunch of various fixes
+
+* Tue May 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - MyPLC-4.2-15
+- Removed proper ops from planetflow slice.
+
+* Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-14
+- myplc-native requires myplc-docs
+- fixed doc build by locating locally installed DTDs at build-time
+
+* Sun May 11 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-13
+- turn myplc-docs off for now
+
+* Sat May 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-12
+- figures in doc package
+
+* Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-11
+- no more doc packaged outside of myplc-docs - doc/ cleaned up 
+- chroot packaging does not have docs anymore
+- 'cvs' and 'dev' not required from myplc-native anymore
+- cosmetic change in kml output
+
+* Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-10
+- defaults for *_IP conf vars now void, expect more accurate /etc/hosts
+- gethostbyname uses python rather than perl (hope this shrinks deps) 
+- doc: reviewed myplc doc - deprecated everything related to myplc-devel
+- doc: packaging doc in myplc-native (myplc&PLCAPI) & removed target files from svn
+- make sync now works towards vserver-based myplc only 
+
+* Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-9
+- 
+- added vsys 'pfmount' script to the default netflow slice attributes.
+- 
+
 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
 - plc.d/bootcd step altered for handling legacy bootcd smooth migration
 - to new bootcd packaging
@@ -241,3 +281,5 @@ fi
 
 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
 - initial build.
+
+%define module_current_branch 4.2