Add the necessary 'vsys' script attribute to the default <site>_netflow slice.
[myplc.git] / myplc-native.spec
index 37ac24c..ebc137e 100644 (file)
@@ -1,16 +1,28 @@
-Vendor: PlanetLab
-Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 4.0
-URL: http://cvs.planet-lab.org/cvs/myplc
+#
+# $Id$
+#
+%define url $URL$
+
+%define name myplc-native
+%define version 4.2
+%define taglevel 8
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Summary: PlanetLab Central (PLC) Portable Installation
-Name: myplc-native
-Version: 0.5
-Release: 4%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+Name: %{name}
+Version: %{version}
+Release: %{release}
 License: PlanetLab
 Group: Applications/Systems
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildArch: noarch
+
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
 
 Requires: bzip2
 Requires: sendmail-cf
@@ -24,6 +36,7 @@ Requires: expect
 Requires: php-pgsql
 Requires: curl
 Requires: python-pycurl
+Requires: python-psycopg2
 Requires: httpd
 Requires: rsync
 Requires: mod_python
@@ -34,8 +47,6 @@ Requires: SOAPpy
 Requires: vixie-cron
 Requires: yum
 Requires: php-gd
-Requires: PLCWWW
-Requires: PLCAPI
 Requires: PyXML
 Requires: sendmail
 Requires: python >= 2.4
@@ -50,11 +61,18 @@ Requires: postgresql
 Requires: openssh
 Requires: cvs
 Requires: dev
-Requires: bootcd
+Requires: bootcd-%{pldistro}-%{_arch}
 Requires: dnsmasq
 Requires: diffutils
 Requires: gzip
 Requires: findutils
+# planetlab stuff
+Requires: PLCWWW
+Requires: nodeconfig
+Requires: PLCAPI
+Requires: bootstrapfs-%{pldistro}-%{_arch}
+
+Provides: myplc
 
 %define debug_package %{nil}
 
@@ -73,11 +91,12 @@ system.
 %build
 pushd MyPLC
 rm -rf $RPM_BUILD_ROOT
-./build-native.sh $RPM_BUILD_ROOT
+./build-native.sh %{pldistro} $RPM_BUILD_ROOT
 popd
 
 %install
 
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -132,6 +151,10 @@ if [ -x /sbin/chkconfig ] ; then
     /sbin/chkconfig --add plc
     /sbin/chkconfig plc on
 fi
+pushd /usr/share/myplc &> /dev/null
+python plc_config.py build
+python plc_config.py install
+popd &> /dev/null
 
 %triggerpostun -- %{name}
 # 0 = erase, 1 = upgrade
@@ -160,20 +183,61 @@ fi
 %files
 %defattr(-,root,root,-)
 # Host startup script and configuration file
+/etc/myplc-release
 /etc/init.d/plc
+/etc/plc.d
+/etc/planetlab
+/etc/plc_sliceinitscripts/sirius
+/etc/support-scripts/gen_aliases.py*
+/etc/support-scripts/renew_reminder.py*
+/var/www/html/install-rpms/%{pldistro}-%{_arch}
+/var/www/html/install-rpms/planetlab
 /usr/bin/plc-config
 /usr/bin/plc-config-tty
 /usr/bin/db-config
 /usr/bin/dns-config
-#/usr/bin/gen-sites-xml.py*
-#/usr/bin/gen-slices-xml-05.py*
-#/usr/bin/gen-static-content.py*
-/etc/plc.d
-/etc/planetlab
-/var/www/html/install-rpms/planetlab
+/usr/bin/plc-map.py*
+/usr/bin/clean-empty-dirs.py*
+/usr/bin/mtail.py*
+/usr/bin/check-ssl-peering.py*
+/usr/share/myplc
 
 %changelog
+* Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-8
+- plc.d/bootcd step altered for handling legacy bootcd smooth migration
+- to new bootcd packaging
+
+* Wed Apr 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-7
+- changes needed for bootcd 4.2 : new, possible multiple, installation locations, and new rpm name
+
+* Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-6
+- packaging of mplc-release in myplc-native
+- sudoers.php is new to PlanetLabConf (needs nodeconfig-4.2-4)
+- resolv file in /etc/resolv.conf, not plc_resolv.conf
+- improved sirius script
+- remove the 'driver' node-network-setting that was unused, and new 'Multihome' category
+- expires more properly set 
+
+* Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - MyPLC-4.2-4 MyPLC-4.2-5
+- 
+
+* Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.2-3 MyPLC-4.2-4
+- renew_reminder script moved to support-scripts/
+- gen-aliases script added in support-scripts/
+- sirius initscript moved to plc_sliceinitscripts (formerly inlined in db-config)
+- plc-map script : no javascript for googlemap anymore, see new plc-kml script instead
+- nodefamily-aware (creates legacy symlink /var/www/html/install-rpms/planetlab)
+- new native slice attributes 'capabilities', 'vsys' and 'codemux'
+- new setting 'Mom list address' for sending emails to a separate destination
+- starts rsyslogd/syslogd as appropriate
+- expects nodeconfig package (former PlanetLabConf/ dir from PLCWWW)
+- convenience generation of yum.conf in resulting image based on build/mirroring
+
+* Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-4.2-2 myplc-4.2-3
+- refresh-peer.py removed (duplicate with PLCAPI)
+- plc.d/ scripts cleaned up
+- sirius initscript updated
+- slice auto renewal fixed
+
 * Fri Aug 31 2007 Marc E. Fiuczynski <mef@CS.Princeton.EDU>
 - initial build.
-
-