- fix /etc/hosts generation
[myplc.git] / myplc.spec
index 7e0c930..038acca 100644 (file)
@@ -5,7 +5,7 @@ URL: http://cvs.planet-lab.org/cvs/myplc
 
 Summary: PlanetLab Central (PLC) Portable Installation
 Name: myplc
-Version: 0.2
+Version: 0.3
 Release: 1%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 License: BSD
 Group: Applications/Systems
@@ -28,10 +28,7 @@ system.
 
 %build
 pushd myplc
-./build.sh -r 2 -d %{_datadir}
-# Not until we can get the build server to run Fedora Core 4 or an
-# updated version of yum.
-#./build.sh -r 4 -d %{_datadir}
+./build.sh
 popd
 
 %install
@@ -70,6 +67,11 @@ if [ -n "$SUDO_USER" ] ; then
     chown -R $SUDO_USER %{_rpmdir}/%{_arch}
 fi
 
+%pre
+if [ -x %{_sysconfdir}/init.d/plc ] ; then
+    service plc stop
+fi
+
 %post
 chkconfig --add plc
 chkconfig plc on
@@ -77,6 +79,7 @@ chkconfig plc on
 %preun
 # 0 = erase, 1 = upgrade
 if [ $1 -eq 0 ] ; then
+    service plc stop
     chkconfig plc off
     chkconfig --del plc
 fi
@@ -96,7 +99,7 @@ fi
 
 # Data directory
 %dir /plc/data
-%config(noreplace) /plc/data
+%config(noreplace) /plc/data/*
 
 %changelog
 * Wed Apr  5 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.2-1