turn off native drupal user registration upon service plc (re)start
[myplc.git] / myplc.spec
index 1be1eac..0c32e34 100644 (file)
@@ -5,16 +5,15 @@
 
 %define name myplc
 %define version 4.3
-%define taglevel 26
+%define taglevel 36
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
 
-Summary: PlanetLab Central (PLC) Portable Installation
 Name: %{name}
 Version: %{version}
 Release: %{release}
 License: PlanetLab
-Group: Applications/Systems
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildArch: noarch
@@ -24,6 +23,12 @@ Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
 
+
+
+####################### myplc
+Summary: PlanetLab Central (PLC) Portable Installation
+Group: Applications/Systems
+
 # as much as possible, requires should go in the subpackages specfile
 Requires: bzip2
 Requires: tar 
@@ -36,7 +41,6 @@ Requires: php-pgsql
 Requires: curl
 Requires: rsync
 Requires: python-devel
-Requires: vixie-cron
 Requires: yum
 Requires: PyXML
 Requires: createrepo
@@ -51,6 +55,11 @@ Requires: vim-minimal
 Requires: findutils
 Requires: xmlsec1
 Requires: xmlsec1-openssl
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 10
+Requires: cronie
+%else
+Requires: vixie-cron
+%endif
 # planetlab stuff
 Requires: bootmanager
 Requires: bootcd-%{pldistro}-%{_arch}
@@ -58,10 +67,11 @@ Requires: PLCWWW
 Requires: www-register-wizard
 Requires: nodeconfig
 Requires: PLCAPI
-Requires: monitor-pcucontrol
+Requires: pcucontrol
 Requires: bootstrapfs-%{pldistro}-%{_arch}
 Requires: myplc-docs
 Requires: myplc-release
+Requires: myplc-config
 
 # argh - ugly - we might wish to use something from build/config.%{pldistro} instead
 %if "%{pldistro}" == "onelab"
@@ -79,6 +89,18 @@ through a graphical interface. All PLC services are started up and
 shut down through a single System V init script installed in the host
 system.
 
+####################### myplc-config
+
+%package config
+
+Summary: PlanetLab Central (PLC) configuration python module
+Group: Applications/Systems
+Requires: python
+
+%description config
+This package provides the Python module to configure MyPLC.
+
+
 %prep
 %setup -q
 
@@ -144,10 +166,6 @@ if [ -x /sbin/chkconfig ] ; then
     /sbin/chkconfig --add plc
     /sbin/chkconfig plc on
 fi
-pushd /usr/share/myplc &> /dev/null
-python plc_config.py build
-python plc_config.py install
-popd &> /dev/null
 
 %triggerpostun -- %{name}
 # 0 = erase, 1 = upgrade
@@ -183,7 +201,6 @@ fi
 /etc/support-scripts/gen_aliases.py*
 /etc/support-scripts/renew_reminder.py*
 /etc/support-scripts/renew_reminder_logrotate
-/usr/bin/plc-config
 /usr/bin/plc-config-tty
 /usr/bin/db-config
 /usr/bin/dns-config
@@ -194,9 +211,62 @@ fi
 /usr/bin/mtail.py*
 /usr/bin/plc-check-ssl-peering.py*
 /usr/bin/plc-orphan-accounts.py*
-/usr/share/myplc
+/usr/share/myplc/bashrc
+
+%files config
+%defattr(-,root,root,-)
+/usr/bin/plc-config
+%{python_sitearch}/plc_config.py*
+
 
 %changelog
+* Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
+- - fix to make sure when API, BOOT, MONITOR are on the same
+- machine as WWW that the SSL key,cert for WWW takes precedence.
+- - Do proper setup for SSL CA certficate to be used as the server
+- chain.
+
+* Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
+- - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
+
+* Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
+- depend on pcucontrol
+
+* Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
+- * validate input according to type in plc_config
+- * added the _genicw system slice
+- * add tag types for sites and persons
+- * add new tags for nodes and slices for exemption from myops
+
+* Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-32
+- turn off drupal on a box that acts as BOOT server but not as WWW server
+- cleanup some obsolete code for old chroot-jail packaging in the process
+- new bootcd-kernel script for keeping bootcd variants up2date
+
+* Mon Nov 09 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-31
+- Make the /etc/hosts manipulation optional.
+
+* Thu Nov 05 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - MyPLC-4.3-30
+- Fix SetRole.
+
+* Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-29
+- - Added "SetRole()" so that db-config.d/ scriplets can insert roles
+- into the DB.
+- - Added the root ssh key handling support back into plc.d/ssh and the
+- default xml file.  This should be identical to the way it was in
+- rc12.
+- - Added support in the db-config.d/01-init script to register the root
+- ssh public key with the default administrator.  In this way the root
+- ssh key will make it into the root account on the nodes by means of
+- NodeManager's specialaccounts plugin.
+
+* Tue Oct 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-28
+- db-config ignores sliver tags
+- sirius's db-config script renamed (was sirious)
+
+* Tue Oct 13 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-27
+- fix for silverauth - missing tag types now created at plc startup time
+
 * Fri Oct 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-26
 - plc.d/ssl preserves SSL certificates when it thinkfs they're obsolete
 
@@ -276,7 +346,7 @@ fi
 * Wed Apr 29 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-6
 - plc_config.py and plc-config-tty: generalized to work for more diverse
 - MyPLC configurations.
-- plc.d/httpd: only update httpd_conf with /data for chroot'ed MyPLC
+- plc.d/httpd: only update httpd_conf with /data for chroot-ed MyPLC
 - deployments and increase the memory limits in php.ini
 - plc.d/crond: add --full option to vacuumdb