turn off native drupal user registration upon service plc (re)start
[myplc.git] / myplc.spec
index e4a1569..0c32e34 100644 (file)
@@ -8,6 +8,7 @@
 %define taglevel 36
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
 
 Name: %{name}
 Version: %{version}
@@ -40,7 +41,6 @@ Requires: php-pgsql
 Requires: curl
 Requires: rsync
 Requires: python-devel
-Requires: vixie-cron
 Requires: yum
 Requires: PyXML
 Requires: createrepo
@@ -55,6 +55,11 @@ Requires: vim-minimal
 Requires: findutils
 Requires: xmlsec1
 Requires: xmlsec1-openssl
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 10
+Requires: cronie
+%else
+Requires: vixie-cron
+%endif
 # planetlab stuff
 Requires: bootmanager
 Requires: bootcd-%{pldistro}-%{_arch}
@@ -161,10 +166,6 @@ if [ -x /sbin/chkconfig ] ; then
     /sbin/chkconfig --add plc
     /sbin/chkconfig plc on
 fi
-pushd /usr/share/myplc &> /dev/null
-python plc_config.py build
-python plc_config.py install
-popd &> /dev/null
 
 %triggerpostun -- %{name}
 # 0 = erase, 1 = upgrade
@@ -200,7 +201,6 @@ fi
 /etc/support-scripts/gen_aliases.py*
 /etc/support-scripts/renew_reminder.py*
 /etc/support-scripts/renew_reminder_logrotate
-/usr/bin/plc-config
 /usr/bin/plc-config-tty
 /usr/bin/db-config
 /usr/bin/dns-config
@@ -215,7 +215,8 @@ fi
 
 %files config
 %defattr(-,root,root,-)
-/usr/share/myplc/plc_config.py*
+/usr/bin/plc-config
+%{python_sitearch}/plc_config.py*
 
 
 %changelog