Update branch with spec file from previous tag.
[myplc.git] / myplc.spec
index fee5867..2a83e94 100644 (file)
@@ -5,16 +5,15 @@
 
 %define name myplc
 %define version 4.3
-%define taglevel 33
+%define taglevel 38
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
 
-Summary: PlanetLab Central (PLC) Portable Installation
 Name: %{name}
 Version: %{version}
 Release: %{release}
 License: PlanetLab
-Group: Applications/Systems
 Source0: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
 BuildArch: noarch
@@ -24,6 +23,12 @@ Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
 
+
+
+####################### myplc
+Summary: PlanetLab Central (PLC) Portable Installation
+Group: Applications/Systems
+
 # as much as possible, requires should go in the subpackages specfile
 Requires: bzip2
 Requires: tar 
@@ -36,7 +41,6 @@ Requires: php-pgsql
 Requires: curl
 Requires: rsync
 Requires: python-devel
-Requires: vixie-cron
 Requires: yum
 Requires: PyXML
 Requires: createrepo
@@ -51,6 +55,11 @@ Requires: vim-minimal
 Requires: findutils
 Requires: xmlsec1
 Requires: xmlsec1-openssl
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 10
+Requires: cronie
+%else
+Requires: vixie-cron
+%endif
 # planetlab stuff
 Requires: bootmanager
 Requires: bootcd-%{pldistro}-%{_arch}
@@ -62,6 +71,7 @@ Requires: pcucontrol
 Requires: bootstrapfs-%{pldistro}-%{_arch}
 Requires: myplc-docs
 Requires: myplc-release
+Requires: myplc-config
 
 # argh - ugly - we might wish to use something from build/config.%{pldistro} instead
 %if "%{pldistro}" == "onelab"
@@ -79,6 +89,18 @@ through a graphical interface. All PLC services are started up and
 shut down through a single System V init script installed in the host
 system.
 
+####################### myplc-config
+
+%package config
+
+Summary: PlanetLab Central (PLC) configuration python module
+Group: Applications/Systems
+Requires: python
+
+%description config
+This package provides the Python module to configure MyPLC.
+
+
 %prep
 %setup -q
 
@@ -144,10 +166,6 @@ if [ -x /sbin/chkconfig ] ; then
     /sbin/chkconfig --add plc
     /sbin/chkconfig plc on
 fi
-pushd /usr/share/myplc &> /dev/null
-python plc_config.py build
-python plc_config.py install
-popd &> /dev/null
 
 %triggerpostun -- %{name}
 # 0 = erase, 1 = upgrade
@@ -183,7 +201,6 @@ fi
 /etc/support-scripts/gen_aliases.py*
 /etc/support-scripts/renew_reminder.py*
 /etc/support-scripts/renew_reminder_logrotate
-/usr/bin/plc-config
 /usr/bin/plc-config-tty
 /usr/bin/db-config
 /usr/bin/dns-config
@@ -194,9 +211,36 @@ fi
 /usr/bin/mtail.py*
 /usr/bin/plc-check-ssl-peering.py*
 /usr/bin/plc-orphan-accounts.py*
-/usr/share/myplc
+/usr/share/myplc/bashrc
+
+%files config
+%defattr(-,root,root,-)
+/usr/bin/plc-config
+%{python_sitearch}/plc_config.py*
+
 
 %changelog
+* Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
+- Add DRL slice.
+- Generalize bootcd-kernel.
+
+* Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
+- support for fedora 12
+- new package myplc-config for use by sfa
+- drupal user registration turned off
+
+* Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
+- - fix to make sure when API, BOOT, MONITOR are on the same
+- machine as WWW that the SSL key,cert for WWW takes precedence.
+- - Do proper setup for SSL CA certficate to be used as the server
+- chain.
+
+* Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-35
+- - Change sysctl.conf source to be PlanetLabConfsysctl.con rather than the php script.
+
+* Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-34
+- depend on pcucontrol
+
 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - MyPLC-4.3-33
 - * validate input according to type in plc_config
 - * added the _genicw system slice