rename script into renew-reminder.py (dash instead of underscore)
[myplc.git] / myplc.spec
index b9e12ba..85dfdd8 100644 (file)
@@ -1,6 +1,6 @@
 %define name myplc
-%define version 5.3
-%define taglevel 4
+%define version 7.0
+%define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -70,11 +70,7 @@ Requires: plewww
 
 # this technically is a plcapi dependency
 # but it's simpler here for chosing which
-%if "%{distro}" == "Fedora" && %{distrorelease} >= 29
-Requires: python2-mod_wsgi
-%else
-Requires: mod_wsgi
-%endif
+Requires: python3-mod_wsgi
 
 # this technically is a plewww dependency
 # starting with f27 we depend on this new rpm
@@ -93,7 +89,7 @@ Requires: expect
 Requires: php-pgsql
 Requires: curl
 Requires: rsync
-Requires: python-devel
+Requires: python3-devel
 Requires: dnf
 #Requires: PyXML
 Requires: cpio
@@ -122,7 +118,7 @@ package, like bootcd, nodeimage, or bootmanager.
 
 Summary: PlanetLab Central (PLC) configuration python module
 Group: Applications/Systems
-Requires: python
+Requires: python3
 
 %description config
 This package provides the Python module to configure MyPLC.
@@ -139,7 +135,7 @@ rm -rf $RPM_BUILD_ROOT
 
 # Install configuration scripts
 echo "* Installing plc_config.py in %{python3_sitelib}"
-install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/%{python3_sitelib}
+install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/%{python3_sitelib}/plc_config.py
 
 echo "* Installing scripts in /usr/bin"
 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
@@ -291,6 +287,9 @@ fi
 
 
 %changelog
+* Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-7.0-0
+- suitable for python3 on both f27 and f29
+
 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
 - takes care of creating plcapi log file