a first move towards adopting gpgv2
[myplc.git] / myplc.spec
index df27265..b0c92fd 100644 (file)
@@ -1,9 +1,9 @@
 %define name myplc
-%define version 5.3
-%define taglevel 4
+%define version 7.0
+%define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
-%global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
+
 
 Name: %{name}
 Version: %{version}
@@ -70,11 +70,7 @@ Requires: plewww
 
 # this technically is a plcapi dependency
 # but it's simpler here for chosing which
-%if "%{distro}" == "Fedora" && %{distrorelease} >= 29
-Requires: python2-mod_wsgi
-%else
-Requires: mod_wsgi
-%endif
+Requires: python3-mod_wsgi
 
 # this technically is a plewww dependency
 # starting with f27 we depend on this new rpm
@@ -93,7 +89,7 @@ Requires: expect
 Requires: php-pgsql
 Requires: curl
 Requires: rsync
-Requires: python-devel
+Requires: python3-devel
 Requires: dnf
 #Requires: PyXML
 Requires: cpio
@@ -122,7 +118,7 @@ package, like bootcd, nodeimage, or bootmanager.
 
 Summary: PlanetLab Central (PLC) configuration python module
 Group: Applications/Systems
-Requires: python
+Requires: python3
 
 %description config
 This package provides the Python module to configure MyPLC.
@@ -138,9 +134,8 @@ This package provides the Python module to configure MyPLC.
 rm -rf $RPM_BUILD_ROOT
 
 # Install configuration scripts
-echo "* Installing plc_config.py in " ${PYTHON_SITEARCH}
-PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
-install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/${PYTHON_SITEARCH}/plc_config.py
+echo "* Installing plc_config.py in %{python3_sitelib}"
+install -D -m 755 plc_config.py ${RPM_BUILD_ROOT}/%{python3_sitelib}/plc_config.py
 
 echo "* Installing scripts in /usr/bin"
 mkdir -p ${RPM_BUILD_ROOT}/usr/bin
@@ -288,10 +283,13 @@ fi
 %files config
 %defattr(-,root,root,-)
 /usr/bin/plc-config
-%{python_sitearch}/plc_config.py*
-
+%{python3_sitelib}/plc_config.py*
+%exclude %{python3_sitelib}/__pycache__/*.pyc
 
 %changelog
+* Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - myplc-7.0-0
+- suitable for python3 on both f27 and f29
+
 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.3-4
 - takes care of creating plcapi log file