cosmetic, remove unused vars.
[myplc.git] / myplc.spec
index e4a1569..bf760d9 100644 (file)
@@ -8,6 +8,7 @@
 %define taglevel 36
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
 
 Name: %{name}
 Version: %{version}
@@ -161,10 +162,6 @@ if [ -x /sbin/chkconfig ] ; then
     /sbin/chkconfig --add plc
     /sbin/chkconfig plc on
 fi
-pushd /usr/share/myplc &> /dev/null
-python plc_config.py build
-python plc_config.py install
-popd &> /dev/null
 
 %triggerpostun -- %{name}
 # 0 = erase, 1 = upgrade
@@ -200,7 +197,6 @@ fi
 /etc/support-scripts/gen_aliases.py*
 /etc/support-scripts/renew_reminder.py*
 /etc/support-scripts/renew_reminder_logrotate
-/usr/bin/plc-config
 /usr/bin/plc-config-tty
 /usr/bin/db-config
 /usr/bin/dns-config
@@ -215,7 +211,8 @@ fi
 
 %files config
 %defattr(-,root,root,-)
-/usr/share/myplc/plc_config.py*
+/usr/bin/plc-config
+%{python_sitearch}/plc_config.py*
 
 
 %changelog