Setting tag myplc-4.3-47
[myplc.git] / myplc.spec
index 0b017d6..ca9f8c6 100644 (file)
@@ -5,9 +5,10 @@
 
 %define name myplc
 %define version 4.3
-%define taglevel 36
+%define taglevel 47
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
 
 Name: %{name}
 Version: %{version}
@@ -40,7 +41,6 @@ Requires: php-pgsql
 Requires: curl
 Requires: rsync
 Requires: python-devel
-Requires: vixie-cron
 Requires: yum
 Requires: PyXML
 Requires: createrepo
@@ -55,6 +55,11 @@ Requires: vim-minimal
 Requires: findutils
 Requires: xmlsec1
 Requires: xmlsec1-openssl
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 10
+Requires: cronie
+%else
+Requires: vixie-cron
+%endif
 # planetlab stuff
 Requires: bootmanager
 Requires: bootcd-%{pldistro}-%{_arch}
@@ -102,6 +107,7 @@ This package provides the Python module to configure MyPLC.
 %build
 
 %install
+[ -d MyPLC] || ln -s myplc MyPLC
 pushd MyPLC
 rm -rf $RPM_BUILD_ROOT
 ./build.sh %{pldistro} $RPM_BUILD_ROOT
@@ -161,10 +167,6 @@ if [ -x /sbin/chkconfig ] ; then
     /sbin/chkconfig --add plc
     /sbin/chkconfig plc on
 fi
-pushd /usr/share/myplc &> /dev/null
-python plc_config.py build
-python plc_config.py install
-popd &> /dev/null
 
 %triggerpostun -- %{name}
 # 0 = erase, 1 = upgrade
@@ -215,10 +217,46 @@ fi
 %files config
 %defattr(-,root,root,-)
 /usr/bin/plc-config
-/usr/share/myplc/plc_config.py*
+%{python_sitearch}/plc_config.py*
 
 
 %changelog
+* Mon Mar 21 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-47
+- attempt to fix small glitches
+
+* Wed Mar 16 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-46
+- enable short_open_tag for backward compatibility
+
+* Tue Mar 15 2011 S.Çağlar Onur <caglar@verivue.com> - myplc-4.3-45
+- Cherry-pick PHP5 timezone fix form master
+
+* Thu Feb 03 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-44
+- pick the greatest version as a kernel
+
+* Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-43
+- handle directory name changes for myplc-docs package as well
+
+* Thu Jan 06 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - myplc-4.3-42
+- handle directory name changes
+
+* Thu Nov 18 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-41
+- Use correct resolv.conf file.
+
+* Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-40
+- Make dnsmasq usable.
+
+* Wed Nov 17 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-39
+- Allow dnsmasq configuration to be extended.
+
+* Thu Jul 22 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - myplc-4.3-38
+- Add DRL slice.
+- Generalize bootcd-kernel.
+
+* Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - MyPLC-4.3-37
+- support for fedora 12
+- new package myplc-config for use by sfa
+- drupal user registration turned off
+
 * Thu Dec 31 2009 Marc Fiuczynski <mef@cs.princeton.edu> - MyPLC-4.3-36
 - - fix to make sure when API, BOOT, MONITOR are on the same
 - machine as WWW that the SSL key,cert for WWW takes precedence.