- must read /etc/planetlab/plc_config.xml, otherwise changes will always
[myplc.git] / myplc.spec
index d2e5108..d783f72 100644 (file)
@@ -70,6 +70,11 @@ if [ -n "$SUDO_USER" ] ; then
     chown -R $SUDO_USER %{_rpmdir}/%{_arch}
 fi
 
+%pre
+if [ -x %{_sysconfdir}/init.d/plc ] ; then
+    service plc stop
+fi
+
 %post
 chkconfig --add plc
 chkconfig plc on
@@ -96,7 +101,7 @@ fi
 
 # Data directory
 %dir /plc/data
-%config(noreplace) /plc/data
+%config(noreplace) /plc/data/*
 
 %changelog
 * Wed Apr  5 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.2-1