- must read /etc/planetlab/plc_config.xml, otherwise changes will always
[myplc.git] / myplc.spec
index e8f8f10..d783f72 100644 (file)
@@ -70,6 +70,11 @@ if [ -n "$SUDO_USER" ] ; then
     chown -R $SUDO_USER %{_rpmdir}/%{_arch}
 fi
 
+%pre
+if [ -x %{_sysconfdir}/init.d/plc ] ; then
+    service plc stop
+fi
+
 %post
 chkconfig --add plc
 chkconfig plc on