- add more comments to changelog for rc2
[myplc.git] / myplc.spec
index f8ffe98..de7ba0b 100644 (file)
@@ -84,7 +84,7 @@ find devel/data | cpio -p -d -u $RPM_BUILD_ROOT/plc/
 
 # Make sure /cvs is never upgraded once installed by giving it a
 # unique name. A hard-linked copy is made in %post.
-mv $RPM_BUILD_ROOT/plc/devel/data/{cvs,cvs.%{version}-%{release}}
+mv $RPM_BUILD_ROOT/plc/devel/data/{cvs,cvs-%{version}-%{release}}
 
 popd
 
@@ -183,7 +183,7 @@ fi
 # If /cvs does not already exist, make a hard-linked copy of this
 # version's /cvs repository.
 if [ ! -d /plc/devel/data/cvs ] ; then
-    cp -rl /plc/devel/data/{cvs.%{version}-%{release},cvs}
+    cp -rl /plc/devel/data/{cvs-%{version}-%{release},cvs}
 fi
 
 %preun devel
@@ -230,6 +230,17 @@ fi
 %changelog
 * Thu Jul 13 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 0.4-2, 0.5-2
 - MyPLC 0.4 RC2.
+- Fix many spec files (License replaces Copyright).
+- Fix kernel build under gcc32 (module verification bug).
+- Fix vnet build under gcc32
+- Fix PlanetFlow. MySQL RPM postinstall script no longer starts the
+  server. Also, get hostnames list from PLC_WWW_HOST, not
+  www.planet-lab.org.
+- Fix pl_mom/bwmon to use cached values if NM is unresponsive
+- Fix pl_mom/swapmon reset logic to avoid endless loops
+- Remove ksymoops, add kernel-smp to standard PlanetLab package group
+- Add kernel-smp boot support to bootmanager
+- Add badblock search support to bootmanager
 - Build development environment (myplc-devel). Add support for
   building myplc itself inside myplc-devel.
 - Move step-specific initialization to appropriate plc.d scripts