Add systemd script for PLC.
[myplc.git] / myplc.spec
index 1128fbf..f655b87 100644 (file)
@@ -1,6 +1,6 @@
 %define name myplc
 %define version 5.0
-%define taglevel 18
+%define taglevel 19
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -114,6 +114,7 @@ chmod 755 ${RPM_BUILD_ROOT}/usr/bin/*
 # Install initscript 
 echo "* Installing plc initscript"
 install -D -m 755 plc.init ${RPM_BUILD_ROOT}/etc/init.d/plc
+install -D -m 644 plc.service ${RPM_BUILD_ROOT}/lib/systemd/system/plc.service
 
 # Install initscripts
 echo "* Installing plc.d initscripts"
@@ -240,6 +241,7 @@ fi
 /usr/bin/plc-orphan-accounts.py*
 /usr/bin/spot-aliens.py*
 /usr/bin/spot-dup-accounts.sh
+/lib/systemd/system/plc.service
 
 %files config
 %defattr(-,root,root,-)
@@ -248,6 +250,9 @@ fi
 
 
 %changelog
+* Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-19
+- new maintenance/monitoring script spot-aliens to look for glitches in refreshpeer+sfa
+
 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myplc-5.0-18
 - new settings for myslice (comon&tophat) and monitor (db)
 - removed mentions of chroot in description