download and install GeoIP city database
[plstackapi.git] / opencloud.spec
index dab5f11..3420bdf 100644 (file)
@@ -1,6 +1,6 @@
 Summary: OpenCloud core services
 Name: opencloud
-Version: 1.0
+Version: 1.0.7
 Release: 1
 License: GPL+
 Group: Development/Tools
@@ -16,6 +16,8 @@ requires: libxslt-devel
 requires: python-pip
 requires: tar
 requires: gcc
+requires: python-httplib2
+requires: GeoIP
 
 %description
 %{summary}
@@ -42,8 +44,18 @@ pip-python install django-geoposition
 pip-python install django-extensions
 pip-python install django-suit
 pip-python install django-evolution
+pip-python install django-bitfield
+pip-python install django-ipware
 
 easy_install django_evolution
+easy_install python_gflags
+easy_install google_api_python_client
+
+wget -P /usr/lib/python2.7/site-packages/suit/static/suit/js http://code.jquery.com/jquery-1.9.1.min.js
+
+rm -f /usr/share/GeoIP/GeoLiteCity*
+wget -P /usr/share/GeoIP http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
+gzip -d /usr/share/GeoIP/GeoLiteCity*.gz
 
 %install
 rm -rf %{buildroot}
@@ -65,7 +77,10 @@ rm -rf %{buildroot}
 /opt/planetstack/scripts/opencloud initdb
 
 %preun
-rm -rf /opt/planetstack
+if [ "$1" = 0 ] ; then
+    echo "doing preuninstall"
+    rm -rf /opt/planetstack
+fi
 
 %changelog
 * Sat Feb 22 2014  Siobhan Tully  1.0.0